Bug 484996 - Use system-provided mono-addins
Use system-provided mono-addins
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On: 514936
Blocks: 480907
  Show dependency treegraph
 
Reported: 2009-02-10 20:24 EST by Michel Alexandre Salim
Modified: 2009-08-27 18:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.6.0.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 18:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2009-02-10 20:24:56 EST
Description of problem:
F-spot currently bundles its own copy of Mono.Addins, rather than using the one from the mono-addins(-devel) packages.

This is against the guidelines, and causes RPM to wrongfully assume that f-spot provides mono(Mono.Addins), meaning installing other mono-addins-using apps such as Tomboy or Banshee does not pull in mono-addins
 
Version-Release number of selected component (if applicable):
f-spot-0.5.0.3-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Remove mono-addins, if installed. Remove its dependents
2. Install f-spot
3. rpm -q --whatprovides "mono(Mono.Addins)"
4. Install tomboy or banshee
5. Run tomboy or banshee

Actual results:
3): $ rpm -q --whatprovides "mono(Mono.Addins)"
f-spot-0.5.0.3-2.fc10.x86_64

5): fails, since f-spot's private copy of Mono.Addins is not in the expected location
 
Expected results:
f-spot should not provide mono-addins

Additional info:
Comment 1 Michel Alexandre Salim 2009-02-11 08:59:45 EST
Another problem: if installing F-10 from local media only, Tomboy works fine on the default desktop. If the update repository is enabled during install, the copy of f-spot that faux-provides Mono.Addins is pulled in, and thus Tomboy is broken.
Comment 2 Stijn Hoop 2009-05-19 05:02:07 EDT
Tomboy was crashing on my system because of this bug. I see that there is a newer f-spot build for Fedora 11 that fixes this problem, can this be redone for Fedora 10 as well?

http://koji.fedoraproject.org/koji/buildinfo?buildID=98595
Comment 3 Christian Krause 2009-07-31 11:40:59 EDT
Problem is fixed in CVS, however it revealed another minor bug in mono-addins. Once that is fixed, I'll push out an update.
Comment 4 Fedora Update System 2009-08-09 14:17:07 EDT
f-spot-0.6.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/f-spot-0.6.0.0-1.fc10
Comment 5 Fedora Update System 2009-08-10 17:47:31 EDT
f-spot-0.6.0.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update f-spot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8430
Comment 6 Fedora Update System 2009-08-27 18:51:11 EDT
f-spot-0.6.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.