Bug 485009 - Desktop entry should have OnlyShowIn=KDE
Desktop entry should have OnlyShowIn=KDE
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ksshaskpass (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 23:44 EST by Michel Alexandre Salim
Modified: 2009-03-31 16:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.5.1-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 02:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Improve desktop entry (699 bytes, patch)
2009-03-29 16:50 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2009-02-10 23:44:46 EST
Description of problem:
ksshaskpass is a KDE-specific program, as
1) it depends on KDE Wallet
2) GNOME's gnome-keyring-daemon already manages SSH keyrings

However, it ships a desktop file that shows up in the GNOME menu. From the content of the desktop file, it looks like it should be removed altogether; 
if the desktop entry is kept visible in KDE, though, it should have OnlyShowIn=KDE

Version-Release number of selected component (if applicable):
ksshaskpass-0.5.1-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Log on to GNOME
2. Look under Internet section
  
Actual results:
kde4/ksshaskpass.desktop is displayed as "SSH Askpass". When launched, it actually runs ssh-add! Looks to be a left over from the original ssh-askpass source.

Expected results:
No desktop file, or a desktop file that is KDE-specific and calls ksshaskpass

Additional info:
Comment 1 Ville Skyttä 2009-03-29 16:50:19 EDT
Created attachment 337182 [details]
Improve desktop entry

I agree that the desktop entry would be better off just removed altogether.  But in case you decide to keep it, I suggest a few additional improvements to the desktop entry: improve Name, GenericName and Comment, fix missing icon in KDE only setups, see attached patch.
Comment 2 Aurelien Bompard 2009-03-30 02:37:28 EDT
Sorry for not replying earlier.
I'd rather keep the desktop file because the KDE4 tool to add applications on startup is looking for desktop files, but I applied Ville's patch.

Thanks to both of you.
Comment 3 Fedora Update System 2009-03-30 02:55:36 EDT
ksshaskpass-0.5.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ksshaskpass-0.5.1-3.fc10
Comment 4 Fedora Update System 2009-03-31 16:28:29 EDT
ksshaskpass-0.5.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.