Bug 485037 - f-spot-import fails with error dialogue: Error connecting to camera; Received error "Could not lock the device" while connecting to camera
f-spot-import fails with error dialogue: Error connecting to camera; Received...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 05:03 EST by morgan read
Modified: 2009-08-27 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6.0.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 18:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Terminal output as above (1.34 KB, application/octet-stream)
2009-02-11 05:03 EST, morgan read
no flags Details

  None (edit)
Description morgan read 2009-02-11 05:03:10 EST
Created attachment 331545 [details]
Terminal output as above

Description of problem:
* Set up f-spot-import as the default gnome action when a camera is attached via gnome-volume-properties > Cameras > Digital Camera > Command: f-spot-import %u, and nothing happens when camera is attached.
* When f-spot-import is run from terminal once camera is attached, f-spot opens and throws up the error window dialogue:
- Error connecting to camera
- Received error "Could not lock the device" while connecting to camera


Version-Release number of selected component (if applicable):
Installed Packages
f-spot.i386                        0.5.0.3-2.fc10              installed

How reproducible:
Always

Steps to Reproduce:
1. Set up gnome-volume-properties with f-spot-import as in Description above
2. Plug in camera, nothing appears to happen
3. Run f-spot-import from terminal
  
Actual results:
Nothing

Expected results:
f-spot-import dialogue

Additional info:
* Camera is Sony DSC-P8
* Connected via PTP
* Terminal output attached
* Worked fine in f8...
* Camera mounts fine on Desktop and opens with a window that provides: "The media contains digital photos."  And, a button "Open F-Spot Photo Manager"; clicking on that button creates a "waiting" cursor which seems to die followed by some brief disk activity
Comment 1 Christian Krause 2009-07-25 16:10:31 EDT
The problem is fixed in CVS, I've ported the bug fix from F11 to F10.

Please note that even in Fedora 10 the default action for attaching a camera is not handled anymore by gnome-volume-properties but by nautilus.

Open any nautilus window, Edit -> Preferences, Media tab, change the default action for Photos to "Open F-Spot Photo Manger". The bug, that there are more than one entries is also fixed, unfortunately it seems that nautilus caches the data. If the first entry doesn't work, please select the second one.
Comment 2 Fedora Update System 2009-07-25 16:21:00 EDT
f-spot-0.5.0.3-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/f-spot-0.5.0.3-4.fc10
Comment 3 Fedora Update System 2009-07-27 17:34:35 EDT
f-spot-0.5.0.3-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update f-spot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8032
Comment 4 Fedora Update System 2009-08-09 14:17:13 EDT
f-spot-0.6.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/f-spot-0.6.0.0-1.fc10
Comment 5 Fedora Update System 2009-08-10 17:47:36 EDT
f-spot-0.6.0.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update f-spot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8430
Comment 6 morgan read 2009-08-17 06:45:20 EDT
After a hard-drive mishap I'm on f11 now - I can confirm all seems well with f11, but I can no longer help with f10.  Thank you.
Comment 7 Fedora Update System 2009-08-27 18:51:16 EDT
f-spot-0.6.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.