Bug 485045 - PRE-tag blocks flow off right edge of page on fedoraproject.org/wiki site
PRE-tag blocks flow off right edge of page on fedoraproject.org/wiki site
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All All
low Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 05:57 EST by "FeRD" (Frank Dana)
Modified: 2009-08-05 14:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 09:48:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example fedoraproject.org/wiki page as rendered in Firefox3, demonstrating badly formatted PRE (154.92 KB, image/png)
2009-02-11 05:57 EST, "FeRD" (Frank Dana)
no flags Details

  None (edit)
Description "FeRD" (Frank Dana) 2009-02-11 05:57:45 EST
Created attachment 331549 [details]
Example fedoraproject.org/wiki page as rendered in Firefox3, demonstrating badly formatted PRE

Description of problem:

Text enclosed inside of a PRE block is formatting poorly on fedoraproject.org/wiki pages, such that it can flow outside the visible page boundaries when the browser window is narrower than the block's rendered size.


How reproducible:

View any page on the wiki containing the HTML PRE tags, resize browser window narrower than the rendered size of that text block.

See attached screenshot for one such example. (Arrows indicate locations where rendering problem occurs.)

  
Actual results:

Text extends outside the visible boundaries of the formatted page, becoming invisible and inaccessible except by widening the browser. For users on smaller displays / when viewing particularly wide blocks of PRE text, the size necessary to view all page elements becomes greater than the maximum visible width of the browser.


Expected results:

Can a brother score a scroll bar?

Ideally, I'd think, blocks wider than the page formatting would become individually scrollable (horizontally, at a minimum).

The other immediately-obvious workaround would involve widening the page to accomodate all PRE blocks (thus making the browser pane horizontally-scrollable at the page level). This would cause wider PRE blocks to force an uncomfortably wide page rendering, requiring horizontal scrolling in order to read any content. As the readability impact of horizontal scrolling (in many languages) is quite severe, the net result of such a change would be a less readable page.

Horizontal scrolling makes sense only in limited use, to overcome issues such as this PRE breakage. Considering some situations leave the content in question completely invisible, ANY level of readability would be an improvement.


Additional info:

I tested this in only one browser:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020410 Fedora/3.0.6-1.fc10 Firefox/3.0.6

Other browsers may result in different formatting, and perhaps even display the same content in such a way that PRE text is never unviewable.

However, considering the penetration of Firefox 3 within Fedora installations themselves, it's especially critical that the wiki display correctly when using that browser.
Comment 1 Karsten Wade 2009-02-11 11:15:48 EST
Yeah, I think what needs to happen is the <pre> box becomes a sideways scrolling window, which we should be able to handle in the CSS, right?
Comment 2 Craig Thomas 2009-02-11 12:12:42 EST
I have committed a fix for this :

diff --git a/fedoraproject.org/static/css/fedora.css b/fedoraproject.org/static/css/fedora.css

index df69b7d..4a5cabc 100644 (file)

--- a/fedoraproject.org/static/css/fedora.css
+++ b/fedoraproject.org/static/css/fedora.css

@@ -23,6 +23,7 @@ a img

 pre

 {

   font-size: 2.6ex;

+  overflow: auto;

 }

 

 #wrapper
Comment 3 "FeRD" (Frank Dana) 2009-02-12 00:56:28 EST
Wow, that was a simple and elegant patch!

After a forced reload of the page, the new rendering looks good -- the wide PRE sections scroll to provide full visibility (and allow extra vertical space for the scrollbar, so there's no vertical scrolling side-effect), and everything else on the page is unaffected.

Thanks for the quick attention!
Comment 4 "FeRD" (Frank Dana) 2009-03-03 03:23:25 EST
..Noticed this bug in my reporting list. I don't know the usual steps, but as the problem was fixed overnight and has remained fixed for over 3 weeks, presumably this can be closed?

As reporter it seems I'm able to do that... but I'm not sure I "should".
Comment 5 Karsten Wade 2009-03-04 09:48:01 EST
Closed, thanks.
Comment 6 Karsten Wade 2009-03-04 10:57:25 EST
Sorry, one last comment I forgot to make.  It is perfectly fine for a reporter to close a bug after confirming that it is indeed fixed or the solution is otherwise acceptable.  Thanks again for following through with filing this bug. :)
Comment 7 eric@christensenplace.us 2009-08-05 14:43:30 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.