Bug 485085 - SSM error changing base channel to "System Default Base Channel"
SSM error changing base channel to "System Default Base Channel"
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-02-11 10:12 EST by Jay Dobies
Modified: 2009-03-03 11:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 11:24:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-02-11 10:12:14 EST
Description of problem:
A null pointer exception is thrown in the logs when I attempt to make the change.

Version-Release number of selected component (if applicable):
Spacewalk 0.5, local build as of Feb 11

How reproducible:
Always

Steps to Reproduce:
1. Selected one system into the SSM
2. Clicked Channels -> Base Channel
3. In the "Desired Base Channel" list, I selected "System Default Base Channel"
4. When I hit confirm, I get an ISE
  
Actual results:
ISE in the UI. Null pointer exception in the logs:

Caused by: java.lang.NullPointerException
	at com.redhat.rhn.frontend.action.channel.ssm.BaseSubscribeAction.confirmUpdateBaseChannels(BaseSubscribeAction.java:172)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[snip]

Expected results:
I'm not fully sure. It's already subscribed to the default channel, so I'm expecting either a confirmation that it was successful or a message that no changes were made.

Additional info:
Comment 1 Jay Dobies 2009-02-11 10:15:18 EST
This might be related to BZ 420601.
Comment 2 Jay Dobies 2009-02-11 10:21:40 EST
Another note, this only seems to happen if it is already subscribed to the default channel and I select to subscribe to the default channel. I was able to change to a user created channel and then back to the default channel successfully.
Comment 3 Jay Dobies 2009-03-03 11:24:09 EST
It looks like this had something to do with the way I syncced my channels. I tried on a 5.3 build that was syncced properly and I don't see the issue.

Note You need to log in before you can comment on or make changes to this bug.