Bug 485094 - [PATCH] /sbin/fence_lpar - properly report status on systems in Open Firmware
[PATCH] /sbin/fence_lpar - properly report status on systems in Open Firmware
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On: 481566
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 11:03 EST by Marek Grac
Modified: 2016-04-26 13:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 481566
Environment:
Last Closed: 2009-05-15 15:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2009-02-11 11:03:22 EST
+++ This bug was initially created as a clone of Bug #481566 +++

+++ This bug was initially created as a clone of Bug #472781 +++

Description of problem:

/sbin/fence_lpar doesn't properly report power status when an lpar is in Open Firmware.

Version-Release number of selected component (if applicable):
cman-2.99.12-1.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot a system into open firmware
2. Run fence_lpar poweroff or reboot ... it thinks it's already powered off.

The following change to /sbin/fence_lpar fixes the problem...

    ## Transformation to standard ON/OFF status if possible
    if status in ["Running", "Open Firmware"]:
        status = "on"
    else:
        status = "off"

--- Additional comment from fedora-triage-list@redhat.com on 2008-11-26 00:52:12 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

--- Additional comment from jlaska@redhat.com on 2008-12-11 11:04:01 EDT ---

Update, in order for reboot operations to work properly ...


--- /sbin/fence_lpar	2008-12-11 11:02:01.000000000 -0500
+++ /tmp/fence_lpar.new	2008-12-11 11:01:59.000000000 -0500
@@ -33,7 +33,7 @@
 
 	##
 	## Transformation to standard ON/OFF status if possible
-	if status == "Running":
+	if status in ["Running", "Open Firmware", "Shutting Down"]:
 		status = "on"
 	else:
 		status = "off"

Without this fix.  I can 

1) Power off
2) It sees the state "Shutting Down" and thinks that means it's off.
3) I then run power on ... and it fails since the machine is still in "Shutting Down" state.

--- Additional comment from fdinitto@redhat.com on 2009-01-28 01:49:06 EDT ---

FYI this issue is now fixed in rawhide. Updates to F10 and F9 will come soon.

Fabio
Comment 2 Perry Myers 2009-05-15 15:07:29 EDT
LPAR is not supported in RHEL4.  It will only be supported in RHEL5, so closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.