Bug 485120 - Changing org name breaks kickstarts
Changing org name breaks kickstarts
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
Depends On:
Blocks: space05 swcobbler05
  Show dependency treegraph
 
Reported: 2009-02-11 12:57 EST by Mike McCune
Modified: 2012-03-06 03:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-02-11 12:57:14 EST
We store our kickstarts in:

/var/lib/rhn/kickstarts

They are named:

<profile-name>--<orgid>--<Org Name>.cfg

eg:

f9-i386--1--Shannon_Hughes.cfg

If the user re-activates their satellite with a new cert that has a different Org Name this will cause kickstarts to break because the cobbler profile will still have the *old* kickstart cfg file in its record:

kickstart : /var/lib/rhn/kickstarts/f9-i386--1--Spacewalk_Public_Cert.cfg

we need to go through and correct all the cobbler profiles 'kickstart' fields if the org name changes.
Comment 1 Mike McCune 2009-02-24 17:52:41 EST
Also noticed that changing the label of a kickstart profile in Spacewalk's GUI causes a 500 error:

redstone.xmlrpc.XmlRpcFault: exceptions.TypeError:update() takes at most 2 arguments (4 given)
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at org.cobbler.CobblerConnection.invokeMethod(CobblerConnection.java:102)
	at org.cobbler.CobblerConnection.invokeTokenMethod(CobblerConnection.java:138)
	at org.cobbler.CobblerObject.setName(CobblerObject.java:276)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileEditCommand.store(CobblerProfileEditCommand.java:56)
Comment 2 Justin Sherrill 2009-02-26 15:35:07 EST
So now kickstarts will be created in 

/var/lib/rhn/kickstarts/upload
/var/lib/rhn/kickstarts/wizard 

depending on type.  We create the file with  'label-orgid.cfg'  but never actually rename it.  If the user wants to he can rename it in cobbler.

So now we pull the filename from cobbler and just figure it out every time.
Comment 3 Justin Sherrill 2009-02-26 16:04:33 EST
commit	1002da08c37b40d04b3f2655f688389ebb09f766

tree	aa8c4fcea5a73f5cf9d05ac2367b16a9119fcb2e	tree | snapshot

parent	565e67f3662cbe5e0fce10d557142051b909a3b8	commit | diff
Comment 4 Jesus M. Rodriguez 2009-04-14 10:12:59 EDT
Spacewalk 0.5 released.
Comment 5 Miroslav Suchý 2009-09-17 03:10:11 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.