Bug 485127 - RFE to increase column size for rhnSourceRPM
RFE to increase column size for rhnSourceRPM
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Ortel
Jesus M. Rodriguez
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-02-11 13:43 EST by Jeff Ortel
Modified: 2009-09-17 03:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 480024
Environment:
Last Closed: 2009-09-17 03:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Ortel 2009-02-11 13:43:24 EST
Exception Handler Information
Traceback (most recent call last):
 <snip>
   self.backend.lookupSourceRPMs(self.sourceRPMs)
 File "/usr/share/rhn/server/importlib/backend.py", line 377, in
lookupSourceRPMs
   self.__processHash('rhnSourceRPM', 'name', hash)
 File "/usr/share/rhn/server/importlib/backend.py", line 953, in
__processHash
   h.executemany(id=ids, value=values)
 File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 103, in
executemany
   return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
 File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 132, in
_execute_wrapper
   raise apply(sql_base.SQLError, ret)
SQLError: (1401, 'ORA-01401: inserted value too large for columnn',
'insert into rhnSourceRPM (id, name) values (:id, :value)')

The sql table looks as such:

SQL> desc rhnSourceRPM
Name                                      Null?    Type
----------------------------------------- --------
ID                                        NOT NULL NUMBER
NAME                                      NOT NULL VARCHAR2(128)

Please increase the maximum values for this and other tables in RHN that
deal with RPM names.


How reproducible:

Always.

Steps to Reproduce:
1. rhn_push a package with a name larger then 128 characters.
2.
3.
  
Actual results:

Raises exception ^^


Expected results:

Should just work.


Additional info:
Comment 1 Jeff Ortel 2009-02-11 13:56:54 EST
Increased the 'name' column in rhnSourceRPM and rhnPackageName tables to 256.  Not knowing how much larger this needs to be, I just doubled it.

git commit: 95c6226..f5c803d
Comment 2 Shannon Hughes 2009-02-20 15:47:56 EST
*** Bug 480252 has been marked as a duplicate of this bug. ***
Comment 7 Jesus M. Rodriguez 2009-04-14 10:13:02 EDT
Spacewalk 0.5 released.
Comment 8 Miroslav Suchý 2009-09-17 03:10:15 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.