Bug 485128 - gnome-keyring updates after 2.25.4.2-1.fc11 break ssh-add
gnome-keyring updates after 2.25.4.2-1.fc11 break ssh-add
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 13:55 EST by Tom "spot" Callaway
Modified: 2015-03-03 17:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 11:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2009-02-11 13:55:11 EST
In my .bash_profile, I have:

SSHAGENT=/usr/bin/ssh-agent
SSHAGENTARGS="-s"
if [ -z "$SSH_AUTH_SOCK" -a -x "$SSHAGENT" ]; then
   eval `$SSHAGENT $SSHAGENTARGS`
   trap "kill $SSH_AGENT_PID" 0
fi

When I login to GNOME, I open an gnome-terminal and run "ssh-add", then type in my passphrase. This has worked for several Fedora releases, to save me the time and loss of sanity that typing my passphrase 400 times costs.

With all rawhide updates of gnome-keyring after 2.25.4.2-1.fc11, ssh-add no longer works. It says things about being unable to connect to the daemon.

I've tried gnome-keyring-2.25.90-4.fc11 and gnome-keyring-2.25.5-1.fc11. Only by downgrading to 2.25.4.2-1.fc11 can I restore the expected behavior.
Comment 1 Matthias Clasen 2009-02-12 10:24:38 EST
Is gnome-keyring-daemon not getting started, or does it crash ?
Comment 2 Tom "spot" Callaway 2009-02-13 11:30:54 EST
Well, I thought it was crashing, so I updated to gnome-keyring-2.25.90-4.fc11.x86_64 and rebooted... of course, it doesn't fail like it was before. 

If I can reproduce this, I'll reopen it, but it seems to be working fine now.

Note You need to log in before you can comment on or make changes to this bug.