This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 485137 - Make fr(oss) the default French xkb map
Make fr(oss) the default French xkb map
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 14:58 EST by Nicolas Mailhot
Modified: 2014-03-02 11:26 EST (History)
12 users (show)

See Also:
Fixed In Version: anaconda-18.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-02 11:26:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-02-11 14:58:37 EST
There are three main French layouts in xkb

— fr, with no identified maintainer, and very limited features
— fr(latin9), which had been created by the French Linux community to complement fr and allow typing symbols necessary in correct French (added in iso-8859-15, but not present in typewriters or iso-8859-1)
— fr(oss), a refresh of fr(latin9) to take unicode changes into account

Please make fr(oss) the default keyboard for French, as it's the most complete and modern. Ubuntu has already been doing it for several releases. The xkb fr(latin9) is only there for historical purposes.

The corresponding kbd match is still fr-latin9 as updating this one for unicode presented little interest and hopefully we'll generate console maps from xkb someday.
Comment 1 Pierre-YvesChibon 2009-02-12 11:21:33 EST
I ask the french community.

The archive can be found there:
https://www.redhat.com/archives/fedora-fr-list/2009-February/msg00090.html (in french though)
Comment 2 Nicolas Chauvet (kwizart) 2009-03-02 05:04:24 EST
Is it possible to know which changes are needed, so the modification can be tested.
I would like to test building a rawhide LiveCD.

Asked on our forum for a more public audience:
http://forums.fedora-fr.org/viewtopic.php?pid=337250

@clumens
Please don't hesite to request me as a tester for this feature.
Comment 3 Nicolas Mailhot 2009-03-02 13:16:42 EST
It only needs an entry change in the master layout list anaconda uses (it used to live in rhpl IIRC). The layout itself has been shipped in xkeyboard-config for many years, you can test it by selecting the "Alternative" French layout in the GNOME layout selector. It has been discussed in the French community in the past

http://linuxfr.org/2006/09/13/21322.html
Comment 4 Nicolas Chauvet (kwizart) 2009-03-04 19:01:16 EST
So as nobody complained, I think we should get the modification done, asap so it can be tested before the beta.
Comment 5 Nicolas Chauvet (kwizart) 2009-03-10 11:20:26 EDT
Can we have this for the beta ? or is it too late already ?
(might need to ask rel-eng if possible to get tested for the Beta)
Comment 6 Bug Zapper 2009-06-09 07:17:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Nicolas Chauvet (kwizart) 2009-06-30 05:21:39 EDT
Changed to rawhide as this "could be" targeted for F-12
Comment 8 Chris Lumens 2009-08-19 17:15:12 EDT
I believe the keyboard model selections have moved from rhpl to system-config-keyboard.
Comment 9 Bug Zapper 2009-11-16 04:47:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Stéphane Raimbault 2009-12-30 08:50:13 EST
Any news on this front?

It's very disturbing when you come from Ubuntu (e.g. AltGr + Space for unbreakable space doesn't work, the shortcuts to enter French quotes are different).
Comment 11 Adel Gadllah 2010-09-21 09:17:15 EDT
(In reply to comment #8)
> I believe the keyboard model selections have moved from rhpl to
> system-config-keyboard.

Yeah once it is updated in system-config-keyboard, system-setup-keyboard will need to be rebuilt. So reassign to the former.
Comment 12 Stéphane Raimbault 2010-11-17 20:28:34 EST
The wrong French keyboard layout still selected by default on Fedora 14.
How we can help you to close this old bug report?
Comment 13 Nicolas Chauvet (kwizart) 2011-03-21 07:15:04 EDT
Isn't anaconda involved in this process after all ?
Comment 14 Stéphane Raimbault 2012-06-02 15:06:44 EDT
The problem still there with Fedora 17 :(

I've reassigned the bug to anaconda (as for #229269).
https://bugzilla.redhat.com/show_bug.cgi?id=229269

and changed the priority to 'medium', the current default French layout is very painful in command line because it's easy to add unbreakable space instead a plain space (AltGr + space) and it's impossible to see the mistake except when you see your command failed.
Comment 15 Stéphane Raimbault 2012-06-02 17:19:01 EDT
Fedora uses kbd and not xkb as Debian and Ubuntu so it explains the different behaviour.

I try to set the VARIANT to "oss" in /etc/sysconfig/keyboard but I think kbd doesn't support variant.

The latest /usr/lib/kbd/keymaps/i386/azerty/fr.map for kbd-misc package (http://ftp.altlinux.org/pub/people/legion/kbd/, 15 May) contains:

keycode  57 = space            space           
    control keycode  57 = nul             
    alt     keycode  57 = Meta_space 

so I've contacted Andries Brouwer <aeb notspam cwi.nl> to have more information (contact provided in the package).
Comment 16 Chris Lumens 2012-08-03 15:23:11 EDT
I believe this should be fixed in F18 Alpha.  Please test and let us know.
Comment 17 Nicolas Mailhot 2012-08-19 05:31:50 EDT
(In reply to comment #15)
> Fedora uses kbd and not xkb as Debian and Ubuntu so it explains the
> different behaviour.
> 
> I try to set the VARIANT to "oss" in /etc/sysconfig/keyboard but I think kbd
> doesn't support variant.

Yes it exists in xkeyboard-config not kbd. At the time I wrote it I think Debian and Ubuntu were already generating console layouts from xkeyboard-config data so writing kbd defs was not worth the pain

Keyboard layouts are very painful to define as errors creep in easily. Having two different layout databases is insane
Comment 18 Stéphane Raimbault 2013-02-01 05:53:30 EST
(In reply to comment #16)
> I believe this should be fixed in F18 Alpha.  Please test and let us know.

Yes the problem to have different layout databases is fixed but GNOME still offer the old French layout by default so this ticket can't be closed.

https://live.gnome.org/GnomeGoals/KeyboardData
Comment 19 Adam Williamson 2013-05-11 01:11:52 EDT
Okay, we need to keep separate issues separate here. What GNOME does and what anaconda does are - at present - separate (though they should both use mfabian's new lang-table thing in F20, I think).

So can someone please check F18 Final and F19 Beta TC3/TC4 and see if the layout anaconda picks - which it lists as "French (French)" - is the one you want? If so, we can close this bug. If not, we could set it back to ASSIGNED, but it's unlikely to be fixed until lang-table is brought in, because anaconda is just using a very simple heuristic for picking keyboard layouts at present.

If GNOME's behaviour is still not as desired, please open a new one for GNOME. (GNOME's 3.8 behaviour is...well...new? You pick French (France) first, and then it gives you a big list with French (alternative) at the top, then Belgian, then Cameroon, then English with dead keys, then French, then French (Canada)...it seems a bit of a mess.)
Comment 20 Adam Williamson 2013-05-11 01:13:16 EDT
I checked langtable in git and clearly mfabian has read this bug; it has Nic's descriptions in there basically verbatim. So once everything runs off langtable we should definitely be good.
Comment 21 Stéphane Raimbault 2013-05-23 03:21:21 EDT
The problem is present in F18 final.

I'm downloading F19 Beta TC4 to test it.
Comment 22 Adam Williamson 2013-05-23 04:19:09 EDT
Thanks. It likely still has the bug as we haven't changed things much in F19, but we may be able to go to langtable in F20.
Comment 23 Stéphane Raimbault 2013-05-23 09:55:54 EDT
Yes in FC19 TC4, the keyboard still French and not French (alternative).

The list GNOME offers isn't convenient (the sections in the list seems a bit confusing to me). Will langtable tool be used for next GNOME version?
Do I need to post a bug report on GNOME bugzilla?

I answered to a GNOME poll months ago about the best keyboard to use for my language and I see my comments are now stored in this tool :)
https://github.com/mike-fabian/langtable/blob/master/data/keyboards.xml#L432
Comment 24 Adam Williamson 2013-05-23 11:23:34 EDT
Actually, I think anaconda is not using langtable, but gnome-initial-setup may be already.

try this: do an install without creating a user account, boot to the installed system, you should get gnome-initial-setup's user creation mode, pick French and complete the wizard. I think the keyboard layout it automatically selects for you is fr(oss).

At that point I'm not sure precisely what the configuration would be; I *think* your systemwide layout would be French but your user would be configured to use French (alternative) in GNOME.
Comment 25 Adam Williamson 2013-05-29 22:12:13 EDT
Setting back to ASSIGNED as this clearly isn't fixed in F19, but we don't need to do anything terribly special here so long as it's planned to migrate to using langtable for language -> layout associations in F20: once we use langtable this fix will be included. This won't be fixed for F19 (we're not manually tweaking the mappings), so setting to Rawhide.
Comment 26 Vratislav Podzimek 2013-07-12 07:09:44 EDT
Patchset including a patch resolving this issue sent to anaconda-patches.
Comment 27 Nicolas Chauvet (kwizart) 2014-03-02 11:26:24 EST
This is the default for F20, so closing to current release

Note You need to log in before you can comment on or make changes to this bug.