This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 485146 - Mock build fails, koji builds succeeds
Mock build fails, koji builds succeeds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-11 15:54 EST by Nicolas Mailhot
Modified: 2013-01-10 00:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 13:37:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Mock logs (4.97 KB, application/x-bzip)
2009-02-11 15:55 EST, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2009-02-11 15:54:17 EST
Description of problem:

Trying to build
http://www.auroralinux.org/people/spot/review/new/bpg-fonts-20090203-1.fc11.src.rpm

in mock fails (see attached logs)

Trying to scratch-build the same srpm in koji succeeds
http://koji.fedoraproject.org/koji/taskinfo?taskID=1120306

Clearly we are hitting some mock bug (probably because the font autoprovides include the names the font files declare, and those name have a & in them)

Version-Release number of selected component (if applicable):
mock-0.9.14-1.fc11.noarch
Comment 1 Nicolas Mailhot 2009-02-11 15:55:23 EST
Created attachment 331619 [details]
Mock logs
Comment 2 Jesse Keating 2009-02-11 17:27:25 EST
Don't suppose you have this in english?  Would be weird that it would be a mock bug, given that your mock is likely newer than what's on the builders.
Comment 3 Nicolas Mailhot 2009-02-12 13:37:15 EST
Today everything builds so someone fixed his bug.

Good job :p
Comment 4 Jesse Keating 2009-02-12 13:56:07 EST
That sounds more like the repodata you are using was different from what the buildsystem was using.  The static repos only update the symlink on the server once per hour, so there could have been a window in there.

Note You need to log in before you can comment on or make changes to this bug.