Bug 485184 - After latest updates-testing update (xorg 1.5.3-11), keymap has reset to USA
After latest updates-testing update (xorg 1.5.3-11), keymap has reset to USA
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 01:40 EST by Pekka Savola
Modified: 2009-12-18 02:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (840 bytes, text/plain)
2009-02-13 00:45 EST, Pekka Savola
no flags Details
xorg.0.log -- older ones (just one) aren't significantly different (83.39 KB, text/plain)
2009-02-13 00:48 EST, Pekka Savola
no flags Details
.xsession-errors log (6.16 KB, text/plain)
2009-02-26 14:29 EST, bucchie73
no flags Details

  None (edit)
Description Pekka Savola 2009-02-12 01:40:36 EST
Description of problem:

After running yum update this morning (last update about 5 days ago) and restarting, the X keymap had reset from Finnish to USA.  I had to change this back manually.  I suspect recent changes in xorg-server-common package.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.5.3-11

How reproducible:

Use non-default keyboard map, upgrade and restart X.

Additional info:

In System - Preferences - Hardware - Keyboard in layouts Tab after upgrade
I had "Evdev-managed keyboard" and layout "USA".  I had to re-add "Finland" and close those gnome-terminals I had already opened for this to take effect.

It could be possible that this is also due to an earlier update after which I didn't restart X (e.g. previous evdev update).
Comment 1 Matěj Cepl 2009-02-12 15:27:55 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Peter Hutterer 2009-02-12 19:23:21 EST
Did you have the configuration in the 10-x11-input.fdi or just in gnome?
Comment 3 Pekka Savola 2009-02-13 00:45:49 EST
Created attachment 331809 [details]
xorg.conf
Comment 4 Pekka Savola 2009-02-13 00:48:11 EST
Created attachment 331810 [details]
xorg.0.log -- older ones (just one) aren't significantly different
Comment 5 Pekka Savola 2009-02-13 00:51:44 EST
I don't see any relevance with video settings so I'm not going to play around with it.  That seems like an automatic "we didn't even look, but automatically requested more information" question.  This is not encouraging for bug submitters.

Wrt #2, I'm not sure what you mean.  I certainly haven't manually changed those files.  The only '10-x11-input.fdi' file out there is:

/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

The timestamp is 2008-12-13, and the file is from HAL upgrade (hal-0.5.12-14.20081027git.fc10) that was installed on 26.12.2008.  'rpm -V hal' shows empty.

HTH,
Comment 6 Peter Hutterer 2009-02-13 01:50:39 EST
Looking at the log, I can see your layout still showing up there.

(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "fi"


My guess is that a gnome component got updated and some setting got changed there. Could that be a possibility?
Comment 7 Peter Hutterer 2009-02-13 01:51:51 EST
(In reply to comment #5)
> Wrt #2, I'm not sure what you mean.  I certainly haven't manually changed those
> files.  The only '10-x11-input.fdi' file out there is:
> 
> /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi

That's fine then. If you had, this file may have been overwritten, causing the layout changes. Since you haven't, it's a different issue.
Comment 8 Pekka Savola 2009-02-16 05:04:18 EST
Certainly, it's possible that this could be caused by a gnome component upgrade.  The most interesting is "gnome-settings-daemon" on Feb 3, but not really anything else.
Comment 9 Peter Hutterer 2009-02-16 17:21:05 EST
Moving to gnome-settings-daemon.
Comment 10 bucchie73 2009-02-26 14:29:12 EST
Created attachment 333373 [details]
.xsession-errors log

I confirmed same bug, too.

kernel-2.6.27.15-170.2.24.fc10.x86_64
gnome-settings-daemon-2.24.1-7.fc10.x86_64

I use the "jp106" keyboard. I ran "yum update" today, but keymap changed to "USA" automatically. I show below the list of an updated package then.

anacron-2.3-66.fc10.x86_64
crontabs-1.10-26.fc10.noarch
e2fsprogs-1.41.4-1.fc10.x86_64
e2fsprogs-devel-1.41.4-1.fc10.x86_64
e2fsprogs-libs-1.41.4-1.fc10.x86_64
e2fsprogs-libs-1.41.4-1.fc10.i386
fontpackages-filesystem-1.20-1.fc10.noarch
gimp-2.6.5-1.fc10.x86_64
gimp-help-browser-2.6.5-1.fc10.x86_64
gimp-libs-2.6.5-1.fc10.x86_64
gstreamer-plugins-good-0.10.13-1.fc10.x86_64
gvfs-1.0.3-5.fc10.x86_64
gvfs-archive-1.0.3-5.fc10.x86_64
gvfs-fuse-1.0.3-5.fc10.x86_64
gvfs-gphoto2-1.0.3-5.fc10.x86_64
gvfs-obexftp-1.0.3-5.fc10.x86_64
gvfs-smb-1.0.3-5.fc10.x86_64
hal-cups-utils-0.6.19-1.fc10.x86_64
kdelibs-common-4.2.0-15.fc10.x86_64
libgcrypt-1.4.4-1.fc10.x86_64
libgcrypt-1.4.4-1.fc10.i386
libgcrypt-devel-1.4.4-1.fc10.x86_64
libgcrypt-devel-1.4.4-1.fc10.i386
rpm-4.6.0-1.fc10.x86_64
rpm-build-4.6.0-1.fc10.x86_64
rpm-devel-4.6.0-1.fc10.x86_64
rpm-libs-4.6.0-1.fc10.x86_64
rpm-python-4.6.0-1.fc10.x86_64
system-config-printer-1.0.15-1.fc10.x86_64
system-config-printer-libs-1.0.15-1.fc10.x86_64
wpa_supplicant-0.6.4-3.fc10.x86_64
xorg-x11-server-Xdmx-1.5.3-13.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-13.fc10.x86_64
xorg-x11-server-Xvfb-1.5.3-13.fc10.x86_64
xorg-x11-server-common-1.5.3-13.fc10.x86_64
xorg-x11-server-devel-1.5.3-13.fc10.x86_64.x86_64

I already changed setting than " System "→" Setting "→" Hardware "→" Keyboard ". A lot of warning to be related to "keycords" is shown in ".xsession-errors" which I attached now.
Comment 11 bucchie73 2009-03-06 17:45:49 EST
I checked 10-x11-keymap.fdi and 10-keymap.fdi ,
modify /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi; change

<merge key="input.xkb.layout" type="string">us</merge>

to

<merge key="input.xkb.layout" type="string">jp</merge>

Warning of "keycords" passed away from .xsession-errors , and the problem seems to be solved.
Comment 12 Chris Jones 2009-03-17 10:01:07 EDT
I'm also seeing this bug on the 8 F10 desktops in our lab.

Resetting it back to the UK keyboard map with system-config-keyboard doesnt seem to work.
Comment 13 Bug Zapper 2009-11-18 06:05:44 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-12-18 02:54:08 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.