Bug 485202 - Summary: SELinux is preventing the plugin-config (nsplugin_config_t) from executing /usr/java/jre1.6.0_12/plugin/i386/ns7/libjavaplugin_oji.so. Detailed Description: SELinux has denied the plugin-config from executing /usr/java/jre1.6.0_12/plugin/i386
Summary: SELinux is preventing the plugin-config (nsplugin_config_t) from ex...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 05:44 EST by martin.sharratt
Modified: 2009-02-16 13:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 13:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setroubleshoot browser log (3.20 KB, text/plain)
2009-02-12 05:44 EST, martin.sharratt
no flags Details

  None (edit)
Description martin.sharratt 2009-02-12 05:44:16 EST
Created attachment 331675 [details]
setroubleshoot browser log 

Description of problem:
Attempt to add java plugin to browser

Version-Release number of selected component (if applicable):


How reproducible:
Happens every time

Steps to Reproduce:
1. Go to a site that requires java
2. Fail to use site because no java in firefox browser by default
3.  download jre from sun website
4. spend a fair time faffing about trying to find the firefox plugins directory (why is it in /usr/lib/mozilla when there's a /usr/lib/firefox3.0.4 directory)
5. When plugin installed run browser and get error as in attachment

Actual results:
See attachment

Expected results:
It would have been nice if java already enabled - did you think no-one would want it
Additional info:
Comment 1 Daniel Walsh 2009-02-16 13:07:21 EST
Fixed in current policy, please 

yum update selinux-policy-targeted

Note You need to log in before you can comment on or make changes to this bug.