Bug 485206 - Review Request: perl-Hash-Util-FieldHash-Compat - Use Hash::Util::FieldHash or ties, depending on availability
Review Request: perl-Hash-Util-FieldHash-Compat - Use Hash::Util::FieldHash o...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 06:46 EST by Allisson Azevedo
Modified: 2009-02-13 07:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 07:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Allisson Azevedo 2009-02-12 06:46:24 EST
Spec URL: http://allisson.fedorapeople.org/packages/perl-Hash-Util-FieldHash-Compat/perl-Hash-Util-FieldHash-Compat.spec

SRPM URL: http://allisson.fedorapeople.org/packages/perl-Hash-Util-FieldHash-Compat/perl-Hash-Util-FieldHash-Compat-0.03-1.fc10.src.rpm

Description: Under older perls this module provides a drop in compatible api to
Hash::Util::FieldHash using perltie. When Hash::Util::FieldHash is
available it will use that instead.
Comment 1 Parag AN(पराग) 2009-02-12 08:05:46 EST
Review:
+ package builds in mock (rawhide i386).
koji build =>http://koji.fedoraproject.org/koji/taskinfo?taskID=1121479
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
7f5c4a37f1e3d9eb9530597fca299825  Hash-Util-FieldHash-Compat-0.03.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is NOT present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test outputs
All tests successful.
Files=1, Tests=27,  0 wallclock secs ( 0.01 usr  0.00 sys +  0.03 cusr  0.00 csys =  0.04 CPU)
+ Package  perl-Hash-Util-FieldHash-Compat-0.03-1.fc11 ->
Provides: perl(Hash::Util::FieldHash::Compat) perl(Hash::Util::FieldHash::Compat::Destroyer) perl(Hash::Util::FieldHash::Compat::Tie::FieldHash) perl(Hash::Util::FieldHash::Compat::Tie::IdHash)
Requires: perl(Scalar::Util) perl(Tie::Hash) perl(Tie::RefHash::Weak) perl(constant) perl(strict) perl(vars) perl(warnings)


 APPROVED.
Comment 2 Allisson Azevedo 2009-02-12 08:09:29 EST
New Package CVS Request
=======================
Package Name: perl-Hash-Util-FieldHash-Compat
Short Description: Use Hash::Util::FieldHash or ties, depending on availability
Owners: allisson
Branches: F-9 F-10
Comment 3 Kevin Fenzi 2009-02-13 01:49:52 EST
cvs done.

Note You need to log in before you can comment on or make changes to this bug.