Bug 485216 - Applications using phonon segfault on exit
Applications using phonon segfault on exit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: phonon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 08:18 EST by Julian Sikorski
Modified: 2009-02-13 07:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 07:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2009-02-12 08:18:57 EST
Description of problem:
After I updated to phonon-4.3.0-5.fc10, applications using it started to segfault on exit. Even the most basic example does:

(gdb) bt
#0  0x00007ffff2e39840 in QPalette::setColor ()
    at /usr/include/QtGui/qpalette.h:191
#1  QPalette::setColor () at /usr/include/QtGui/qpalette.h:193
#2  X11Renderer (this=0x7ffff2e39840, videoWidget=0x7fffffffe1a0)
    at /usr/src/debug/phonon-4.3.0/gstreamer/x11renderer.cpp:68
#3  0x0000000000000000 in ?? ()
(gdb) bt full
#0  0x00007ffff2e39840 in QPalette::setColor ()
    at /usr/include/QtGui/qpalette.h:191
No locals.
#1  QPalette::setColor () at /usr/include/QtGui/qpalette.h:193
No locals.
#2  X11Renderer (this=0x7ffff2e39840, videoWidget=0x7fffffffe1a0)
    at /usr/src/debug/phonon-4.3.0/gstreamer/x11renderer.cpp:68
No locals.
#3  0x0000000000000000 in ?? ()
No symbol table info available.

Version-Release number of selected component (if applicable):
phonon-4.3.0-5.fc10

How reproducible:
always

Steps to Reproduce:
1. grab the phonon example from http://doc.trolltech.com/4.4/phonon-musicplayer.html
2. build it
3. run it
4. exit
  
Actual results:
Program segfaults

Expected results:
Program exits cleanly

Additional info:
It happens with qmc2 as well. What is even more strange, according to systemsettings phonon is supposed to use xine, not gstreamer.
Comment 1 Rex Dieter 2009-02-12 09:01:44 EST
Be aware that the phonon-musicplayer code mentioned was intended for phonon-4.0, which is/was distributed along with qt, not the standalone phonon (now version 4.3) distributed separately.

That said, one would hope there was no intention for any api/abi breakage as seen here.
Comment 2 Kevin Kofler 2009-02-12 14:57:03 EST
It's quite possible the settings in systemsettings are only honored by KDE apps.

The best way to get rid of the broken GStreamer backend is to rpm -e phonon-gstreamer.
Comment 3 Kevin Kofler 2009-02-12 14:58:01 EST
Sorry, that would be: rpm -e phonon-backend-gstreamer
Comment 4 Julian Sikorski 2009-02-13 06:49:41 EST
It does not help, the following backtrace is with the gstreamer backend removed. Btw, do you have any ideas how to make #0 more verbose?
(gdb) bt
#0  0x0000000000c88840 in ?? ()
#1  0x0000003c6a342945 in qt_call_post_routines ()
    at kernel/qcoreapplication.cpp:159
#2  0x0000003f1a18b828 in ~QApplication (this=0x7fffffffe200)
    at kernel/qapplication.cpp:938
#3  0x0000000000404c9d in main (argv=1, args=<value optimized out>)
    at main.cpp:33
(gdb)
Comment 5 Julian Sikorski 2009-02-13 07:23:12 EST
OK, now that's weird. I pulled the rest of KDE 4.2 update and the segfault is no longer there. Even with gstreamer backend installed.

Note You need to log in before you can comment on or make changes to this bug.