Bug 485221 - traceback on failing trigger
traceback on failing trigger
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 09:00 EST by Yanko Kaneti
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 10:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2009-02-12 09:00:51 EST
For a local reasons the trigger for flash-plugin on firefox update is failing.
yum-3.2.21-9.fc11.noarch is failing with this traceback.

  Updating       : firefox                                                            1/2 
/var/tmp/rpm-tmp.cu8c88: line 1: /usr/lib/flash-plugin/setup: Permission denied
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 389, in callback
    self._scriptError(bytes, total, h)
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 519, in _scriptError
    msg = "Non-fatal %s scriptlet failure in rpm package %s" % (rpm.tagnames[bytes], txmbr.po)
KeyError: 1100L
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0xbb1e96c>> failed, aborting!

Tracked to yum-HEAD.patch. Disabling the patch gives the expected output.
  Updating       : firefox                                                            1/2 
/var/tmp/rpm-tmp.qqVpkj: line 1: /usr/lib/flash-plugin/setup: Permission denied
warning: %triggerin(flash-plugin-10.0.15.3-release.i386) scriptlet failed, exit status 126
  Cleanup        : firefox                                                            2/2
Comment 1 James Antill 2009-02-12 10:20:34 EST
 I've fixed this upstream, as it's a really bad idea to fail in rpm callbacks. However rpm shouldn't be giving us internal only tagnames ... so I'm going to reassign this too.

% fgrep 1100 -r /usr/include/rpm
/usr/include/rpm/rpmlib.h:    RPMTAG_TRIGGERIN		= 1100, /*!< internal */
Comment 2 seth vidal 2009-02-12 10:26:05 EST
Thanks - looks like something changed the type it was using. I've made a change to make sure it doesn't catch us again.

Note You need to log in before you can comment on or make changes to this bug.