Bug 485225 - Upgrade NetworkManager-vpnc to work with NetworkManager-0.7.0-3.el5
Upgrade NetworkManager-vpnc to work with NetworkManager-0.7.0-3.el5
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 09:07 EST by Alexander Todorov
Modified: 2009-06-08 09:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 05:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Importing pcf file error (17.10 KB, image/png)
2009-04-12 19:41 EDT, Taunus
no flags Details

  None (edit)
Description Alexander Todorov 2009-02-12 09:07:19 EST
Description of problem:

# yum install  NetworkManager-vpnc
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager-vpnc.i386 1:0.6.4-3.el5 set to be updated
--> Processing Dependency: vpnc >= 0.3.3-3 for package: NetworkManager-vpnc
--> Running transaction check
---> Package vpnc.i386 0:0.4.0-2.el5 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0-2
--> Finished Dependency Resolution
1:NetworkManager-0.7.0-3.el5.i386 from installed has depsolving problems
  --> NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-vpnc


Version-Release number of selected component (if applicable):
NetworkManager-vpnc.i386 1:0.6.4-3.el5
NetworkManager-0.7.0-3.el5

How reproducible:
Always

Steps to Reproduce:
1. Configure EPEL on RHEL5.3 box
2. Try to install NetworkManager-vpnc
  
Actual results:
rpm transaction fails

Expected results:
package is installed.

Additional info:
EPEL doesn't provide newer version of the package which works with newer versions of NM.
Comment 1 Aleksey Nogin 2009-04-01 11:47:42 EDT
This causes problems with 5.2 -> 5.3 upgrades when NetworkManager-vpnc is already installed:

# yum upgrade
...
--> Finished Dependency Resolution
Error: NetworkManager conflicts with NetworkManager-vpnc < 1:0.7.0-2

Bumping severity due to this.
Comment 2 Lubomir Rintel 2009-04-02 03:12:56 EDT
So I've updated the package for EL-5, but it doesn't build due a buildsystem problem:

https://fedorahosted.org/fedora-infrastructure/ticket/1308#preview

Until it is fixed, Alexander, could you please build it from CVS checkout and try it out? I don't have an EL-5 around here, and in work we don't have a cisco VPN.

While at this, it's some time since EL 5.3 was released. It would be nice if this had an active maintainer (I believe Huzaifa is going to take care of that).
Comment 3 Lubomir Rintel 2009-04-02 10:38:17 EDT
Built. Grab the packages from here:

http://buildsys.fedoraproject.org/plague-results/fedora-5-epel/NetworkManager-vpnc/0.7.0.99-1.el5.2/

Please let me know if that works for you.
Comment 4 Taunus 2009-04-08 08:12:41 EDT
It does not work. If you click "Add" and then new vpnc connection, it will seg fault. Editing an old vpnc connection will segfault too.

Here is the end of an strace log:

connect(16, {sa_family=AF_FILE, path="/tmp/keyring-95ysUG/socket"}, 110) = 0
fcntl(16, F_GETFL)                      = 0x2 (flags O_RDWR)
write(16, "\0", 1)                      = 1
write(16, "\0\0\0\34\0\0\0\24nm-connection-editor\0\0\0\211"..., 165) = 165
read(16, "\0\0\0\10", 4)                = 4
read(16, "\0\0\0\1", 4)                 = 4
close(16)                               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 5 Lubomir Rintel 2009-04-10 08:42:31 EDT
http://buildsys.fedoraproject.org/plague-results/fedora-5-epel/NetworkManager-vpnc/0.7.0.99-1.el5.3/

The crash issue should be fixed. Please retest.
Comment 6 Taunus 2009-04-12 19:41:21 EDT
Created attachment 339270 [details]
Importing pcf file error

Thanks, it works now.

One bug still remains. If you try to import pcf file, you get a error like in the attachment.
Comment 7 Lubomir Rintel 2009-04-19 11:44:17 EDT
(In reply to comment #6)
> Created an attachment (id=339270) [details]
> Importing pcf file error
> 
> Thanks, it works now.
> 
> One bug still remains. If you try to import pcf file, you get a error like in
> the attachment.  

Please open a separate bug report for that.

Is the file name in the screenshot correct?
Did this work before?
Comment 8 Taunus 2009-04-28 06:38:51 EDT
Ok. New bug number 497992
https://bugzilla.redhat.com/show_bug.cgi?id=497992

The file name in the screenshot is not correct. It seems to change randomly every time you try to import a pcf file.

I only know about RHEL 5.3. In my setup within few months it has never worked.
Comment 9 Taunus 2009-04-28 06:46:40 EDT
I mean the plugin and everything works good, importing pcf file does not.
Comment 10 Ian Pilcher 2009-06-08 09:26:38 EDT
Am I the only person who thinks it's inappropriate to close a bug before
it's actually fixed in the main repository?

Note You need to log in before you can comment on or make changes to this bug.