Bug 485243 - vmstat -p broken
Summary: vmstat -p broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps
Version: 4.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Novotny
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-12 15:57 UTC by Petr Šplíchal
Modified: 2016-06-01 01:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 485246 (view as bug list)
Environment:
Last Closed: 2009-05-18 20:04:24 UTC


Attachments (Terms of Use)
patch backported from RHEL5 (3.12 KB, patch)
2009-02-16 11:43 UTC, Daniel Novotny
no flags Details | Diff
the new patch (3.49 KB, patch)
2009-02-18 12:05 UTC, Daniel Novotny
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0950 normal SHIPPED_LIVE procps bug fix update 2009-05-18 13:21:52 UTC

Description Petr Šplíchal 2009-02-12 15:57:10 UTC
Description of problem:
Displaying detailed partition statistics using "vmstat -p <partition>"
does not work on RHEL4. This is due to new /proc/diskstats format.

Version-Release number of selected component (if applicable):
procps-3.2.3-8.12
procps-3.2.3-8.14

Steps to Reproduce:
# grep sda1 /proc/diskstats
   8    1 sda1 33 629 1328 117 0 0 0 0 0 117 117
# vmstat -p /dev/sda1

Actual results:
Partition was not found

Expected results:
sda1          reads   read sectors  writes    requested writes
                 33       1328        0           0

Comment 2 Daniel Novotny 2009-02-16 11:43:48 UTC
Created attachment 332025 [details]
patch backported from RHEL5

Comment 3 Petr Šplíchal 2009-02-17 07:28:24 UTC
This bug concerns broken functionality --> moving priority to medium.
Daniel, thanks for backporting the patch. Can you ack the devel flag so that we can move on? Thanks!

Comment 4 Daniel Novotny 2009-02-17 12:02:42 UTC
fixed in procps-3.2.3-8.15

Comment 7 Daniel Novotny 2009-02-18 12:04:15 UTC
the printf() output format was not adjusted to new variable size of "requested writes" - this affects only big-endian machines


fixed in procps-3.2.3-8.16

Comment 8 Daniel Novotny 2009-02-18 12:05:22 UTC
Created attachment 332365 [details]
the new patch

Comment 11 errata-xmlrpc 2009-05-18 20:04:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0950.html


Note You need to log in before you can comment on or make changes to this bug.