Bug 485252 - plserver exits immediately with no error messages
plserver exits immediately with no error messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: itcl (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 11:31 EST by Nick Maliszewskyj
Modified: 2009-07-22 18:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.4-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Maliszewskyj 2009-02-12 11:31:29 EST
Description of problem:
plserver (plplot-tk-5.9.0-2.svn8752.fc10.i386) exits immediately with
no error messages. It is not possible to use the tcl binding to plplot.

Version-Release number of selected component (if applicable):
plplot-tk-5.9.0-2.svn8752.fc10.i386

How reproducible:
Completely

Steps to Reproduce:
1. Run plserver from the command line
2.
3.
  
Actual results:
Immediate return to command line.

Expected results:
Wish toplevel window revealed and plserver command prompt.

Additional info:
On running strace I find that plserver is attempting to find itcl.tcl in /itcl/library/itcl.tcl and itk.tcl in /itk/library/itk.tcl. The itcl and itk packages put these files under /usr/share/tcl8.5/itcl3.4 and /usr/share/tcl8.5/itk3.4, respectively. It would appear that this is a build problem.
Comment 1 Orion Poplawski 2009-02-12 14:09:53 EST
While plserver should output some useful error messages, I believe this is a problem in itcl.  plserver is basically just calling Itcl_Init() from the itcl library.  It should know how to find itcl.tcl.
Comment 2 Wart 2009-07-11 19:23:48 EDT
The problem is indeed with itcl.  In itcl_cmds.c there is some code that iterates through a list of well-known directories that should contain itcl.tcl.  Unfortunately, /usr/share/tcl8.5/itcl3.4 is not among that list.

I'm working on a patch now.
Comment 3 Fedora Update System 2009-07-11 21:01:00 EDT
itk-3.4-3.fc10,itcl-3.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/itk-3.4-3.fc10,itcl-3.4-3.fc10
Comment 4 Fedora Update System 2009-07-16 03:17:02 EDT
itk-3.4-3.fc10, itcl-3.4-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update itk itcl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7632
Comment 5 Fedora Update System 2009-07-22 18:05:30 EDT
itk-3.4-3.fc10, itcl-3.4-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.