This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 485254 - Cluster startup failure during recovery when persistent JMS messages are used
Cluster startup failure during recovery when persistent JMS messages are used
Status: CLOSED DUPLICATE of bug 486991
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Arnaud Simon
Frantisek Reznicek
IG Index
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 11:36 EST by Arnaud Simon
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 06:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Simon 2009-02-12 11:36:37 EST
Description of problem:
Startup failure during recovery when persistent JMS messages are used. 

Workaround: 
clean the data dir before restart, or use non-per messages.
Comment 1 Gordon Sim 2009-02-17 07:05:49 EST
Arnaud, can you give some details on the nature or the failure?
Comment 2 Arnaud Simon 2009-03-02 06:13:17 EST
Here is the error:
2009-mar-02 12:10:25 debug 192.168.224.71:25030(INIT) config change: 192.168.224.71:25030 192.168.224.71:25005 (joined) 
2009-mar-02 12:10:25 notice Journal "TplStore": Created
2009-mar-02 12:10:25 debug Journal "TplStore": Journal directory = "/home/asimon/.qpidd2/rhm/tpl/"; Base file name = "tpl"
2009-mar-02 12:10:25 notice Store module initialized; dir=/home/asimon/.qpidd2
2009-mar-02 12:10:25 info > Default files per journal: 8
2009-mar-02 12:10:25 info > Default journal file size: 24 (wpgs)
2009-mar-02 12:10:25 info > Default write cache page size: 32 (Kib)
2009-mar-02 12:10:25 info > Default number of write cache pages: 32
2009-mar-02 12:10:25 info > TPL files per journal: 8
2009-mar-02 12:10:25 info > TPL journal file size: 24 (wpgs)
2009-mar-02 12:10:25 info > TPL write cache page size: 4 (Kib)
2009-mar-02 12:10:25 info > TPL number of write cache pages: 64
2009-mar-02 12:10:25 notice Recovering from cluster, no recovery from local journal
2009-mar-02 12:10:25 debug Exception constructed: Exchange already exists: amq.topic (MessageStoreImpl.cpp:489)
2009-mar-02 12:10:25 debug Journal "TplStore": Destroyed
2009-mar-02 12:10:25 critical Broker start-up failed: Exchange already exists: amq.topic (MessageStoreImpl.cpp:489)
Comment 3 Gordon Sim 2009-03-02 06:30:37 EST
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=486991

*** This bug has been marked as a duplicate of bug 486991 ***

Note You need to log in before you can comment on or make changes to this bug.