Bug 485269 - source rpm won't get build in platform not listed in BuildArch
source rpm won't get build in platform not listed in BuildArch
Status: CLOSED DUPLICATE of bug 442105
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-12 12:46 EST by Glauber Costa
Modified: 2009-02-12 13:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-12 13:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Glauber Costa 2009-02-12 12:46:57 EST
Description of problem:

I have a spec file here using the BuildArch directive as follows:

BuildArch: %{ix86}

when I try to create a srpm in another platform, say, x86_64, it fails with the following message:

 error: No compatible architectures found for build

I believe creation of the source rpm itself should be possible to be made
anywhere, regardless of what's found in BuildArch.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. create a spec file using BuildArch: %{ix86}
2. rpmbuild -bs file.spec in anything other than i386
3. whatch the error message
Actual results:

Expected results:

Additional info:
Comment 1 Jindrich Novy 2009-02-12 13:02:48 EST
This one is already fixed upstream.

We may want to backport it to 4.6.0 final.

*** This bug has been marked as a duplicate of bug 442105 ***

Note You need to log in before you can comment on or make changes to this bug.