Bug 485273 - fc10 installation/mkinitrd fails with dmraid (UUID)
fc10 installation/mkinitrd fails with dmraid (UUID)
Status: CLOSED DUPLICATE of bug 476818
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 13:05 EST by Alexander Holler
Modified: 2009-02-12 13:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 13:15:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Holler 2009-02-12 13:05:27 EST
Description of problem:

I've just installed fc10 x86_64 on a dmraid-raid1-partition using a netinstall. After the installation the system started without dmraid, so it destroyed the raid. I've tried to build a working initrd using mkinitrd, but mkinitrd just builded an initrd without dmraid. The raid-hw is a VIA VT6420 but I assume this is not important. The entry for the root-partiton in /etc/fstab used an UUID.
 
Version-Release number of selected component (if applicable):
mkinitrd-6.0.71-3.fc10.x86_64

How reproducible:
every time

Steps to Reproduce:
1. Install FC 10 into a dmraid-partition
2. Boot the freshly installed system
3. Type mount in a session
  
Actual results:
A plain partition is mounted, the raid destroyed.

Expected results:
A dmraid partition should be mounted

Additional info:
Kernel 2.6.27.12-170.2.5.fc10.x86_64
The partition onto which I installed was formatted with ext4.
Bug 478355 is about mdraid and not about dmraid or an installation.
Bug 484120 is about a failed post-installation but not about mkinitrd.
Comment 1 Hans de Goede 2009-02-12 13:15:00 EST
This is a known issue, please restart the installer in rescue mode, then update mkinitrd to this version:
http://koji.fedoraproject.org/koji/buildinfo?buildID=82459

(which is on its way to updates testing), regenerate your initrd and then things should work.

For more details on how to do this see bug 476818.

*** This bug has been marked as a duplicate of bug 476818 ***

Note You need to log in before you can comment on or make changes to this bug.