Bug 485274 - mount: could not find filesystem '/dev/root' - again
mount: could not find filesystem '/dev/root' - again
Status: CLOSED DUPLICATE of bug 480667
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 13:06 EST by keith
Modified: 2009-02-12 13:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 13:25:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description keith 2009-02-12 13:06:15 EST
Description of problem:
Booted the new release of Fedora 11 Alpha, used the install option from the desktop. 
I have two disks, installation was on sda, sdb is my data store and home partition. Other than the config of sdb device config was default (logical volume for /)
All installation went well.
On reboot, I can see plymouth start, then got the following error after the logical volume successful message:
mount: could not find filesystem '/dev/root'

In searching found a similar previous bug for F9 of # 431778 (https://bugzilla.redhat.com/show_bug.cgi?id=431778)

Unlike F9 Alpha, I had no additonal messages

Version-Release number of selected component (if applicable):
Alpha

How reproducible:
On first install so far

Steps to Reproduce:
1. Install alpha
2. Reboot
3.
  
Actual results:
failed to boot on first usage

Expected results:
Boot into Fedora 11

Additional info:
Comment 1 Hans de Goede 2009-02-12 13:25:57 EST
Known issue, to workaround this you need to specify your root on the kernelcmdline (grub) not as UUID= or LABEL=, but directly, see the F11 alpha release notes.

Once you've booted this way do:
yum update mkinitrd

Followed by
yum update kernel

And booting by UUID should work again.

*** This bug has been marked as a duplicate of bug 480667 ***

Note You need to log in before you can comment on or make changes to this bug.