Bug 485306 - missing menu categories
missing menu categories
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 14:18 EST by Rudolf Kastl
Modified: 2010-05-04 02:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: xchat-2.8.6-17.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 02:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (1.18 KB, patch)
2010-04-09 11:51 EDT, Rudolf Kastl
no flags Details | Diff

  None (edit)
Description Rudolf Kastl 2009-02-12 14:18:30 EST
Description of problem:
xchat is missing menu categorys. they should be added with desktop-file-install

comparison against xchat-gnome:

<che> xchat: Categories=Network;
<che> xchat-gnome: Categories=GNOME;GTK;Network;IRCClient;

Version-Release number of selected component (if applicable):
xchat-2.8.6-6.fc11.i386

How reproducible:
always
Comment 1 Bug Zapper 2009-06-09 07:19:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2009-11-16 04:47:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Rudolf Kastl 2010-04-08 00:44:38 EDT
lets skip f13... this package is really awesomely maintained! congrats! ;)
Comment 4 Kevin Kofler 2010-04-08 12:23:45 EDT
Only Network is actually required, and XChat defines that.
Comment 5 Rudolf Kastl 2010-04-09 10:34:54 EDT
there are actual standard that isnt environment specific called xdg and it has IRCClient defined. xchat is just that and one of the only irc clients that arent categorized properly. the fact that the default menus of the so called mainstream desktop environments for linux do not use subcategorys on fedora (and therefor have close to unusable menus for larger installs) is not really an excuse to me. yet i got a few hundred desktop files fixed up and this is really trivial since desktop file install (or atleast desktop file validate should be used in the spec anyways to install the desktop files. 
sorry kevin while i usually value your opinion in this case it wasnt very productive at all. even if the maintainer is stubborn enough to not add it then a simple reply to a bug like that wouldnt really hurt, but i really have the feeling the bug is just beeing ignored: 

http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html

there is alot more i could write and add but it wouldnt help improving the desktop experience at all. it would just get rid of alot frustration that has been accumulated by the desktop experience of the mainstream desktop environments.

if improvement is not welcome i will just move on to do something else like alot others already did.
Comment 6 Kevin Kofler 2010-04-09 10:51:57 EDT
Let's be honest, I'm the only comaintainer of XChat who seems to actually give a darn at all (judging from the lack of replies by anybody else), so as far as I'm concerned you can happily comaintain it if you care about it, then you can fix such things yoursef. :-)

I know the fd.o menu spec. IRCClient is an Additional Category, which means it's not required, only a Main Category is. That said, sure it's nice to add that stuff.
Comment 7 Rudolf Kastl 2010-04-09 11:49:25 EDT
i am also beeing dead honest: if id start comaintaining every component that has ignored bugs (even only those with packages attached) id have a 18 hour day for deliverying the quality i wanted to and no time to get issues like that ahead (it might seem unimportant to some... i have my use cases and no one else is wasting time on it). 
thanks for your honest reply... but the conclusion actually is that this package doesent need another comaintainer but a responsive maintainer that takes care of the package.

patch for getting the above issue (+ 2 cosmetical changes) fixed is attached.
Comment 8 Rudolf Kastl 2010-04-09 11:51:22 EDT
Created attachment 405575 [details]
patch

patch diffed against latest cvs revision of the xchat.spec. quickly looked at it while beeing on the train. couldnt test it because i have to get off (warning... over 26 hours awake cause of changing continents).
Comment 9 Kevin Kofler 2010-04-21 03:04:36 EDT
This is now committed to Rawhide, build started.
Comment 10 Fedora Update System 2010-05-01 15:10:33 EDT
xchat-2.8.6-17.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xchat-2.8.6-17.fc13
Comment 11 Fedora Update System 2010-05-01 15:13:26 EDT
xchat-2.8.6-17.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xchat-2.8.6-17.fc12
Comment 12 Fedora Update System 2010-05-01 15:15:05 EDT
xchat-2.8.6-17.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xchat-2.8.6-17.fc11
Comment 13 Fedora Update System 2010-05-04 02:07:08 EDT
xchat-2.8.6-17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-05-04 02:20:48 EDT
xchat-2.8.6-17.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-05-04 02:22:57 EDT
xchat-2.8.6-17.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.