Bug 485344 - RHEL 5.2 -> 5.3 upgrade installs Xorg, even though you didn't already have it
RHEL 5.2 -> 5.3 upgrade installs Xorg, even though you didn't already have it
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebindings (Show other bugs)
5.3
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 18:29 EST by Dave Miller
Modified: 2014-06-25 17:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 17:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Miller 2009-02-12 18:29:35 EST
Description of problem:
Trying to upgrade from RHEL 5.2 to RHEL 5.3 via "yum update" tries to install Xorg, because it's pulled in by kdebase, which is pulled in by kdebindings, which is pulled as a prereq for "gamin-python".

package: gamin-python.x86_64 0.1.7-8.el5
  dependency: /usr/lib64/python2.4
   provider: kdebindings.x86_64 3.5.4-1.fc6

Version-Release number of selected component (if applicable):
gamin-python.x86_64 0.1.7-8.el5

How reproducible:
Always

Steps to Reproduce:
1. yum update
  
Actual results:
Xorg (and a bunch of other desktop stuff) shows up in the list of things to be installed as dependencies.

Expected results:
A machine without Xorg on it already shouldn't get it pulled in with an update.

Additional info:
"yum provides /usr/lib64/python2.4" tells me the following packages all provide this:

kdebindings-3.5.4-1.fc6.x86_64
python-2.4.3-21.el5.x86_64
1:NetworkManager-devel-0.7.0-3.el5.x86_64

I'm not sure why either kdebindings or NetworkManager-devel show up on that list.  They probably shouldn't.

Workaround:

Add "exclude=kdebindings" to yum.conf, then it properly pulls python-2.4.3-21 to solve this dependency.
Comment 1 Dave Miller 2009-02-12 18:33:48 EST
Hmm, this is actually probably the fault of the "provides" settings in the kdebindings package, so moving it to that component.
Comment 5 RHEL Product and Program Management 2014-03-07 08:55:22 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 Dave Miller 2014-03-07 11:56:59 EST
Fine with me, we no longer use RHEL5 on new installs and have very few machines left running it.
Comment 7 Ondrej Vasik 2014-06-25 17:20:38 EDT
Ok, closing WONTFIX for RHEL 5, thanks for reply.

Note You need to log in before you can comment on or make changes to this bug.