Bug 485361 - INFO test always fail with a tainted kernel value of 16 in RHEL4.7 x86_64
INFO test always fail with a tainted kernel value of 16 in RHEL4.7 x86_64
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 20:56 EST by abel0301
Modified: 2014-03-25 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 21:21:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abel0301 2009-02-12 20:56:56 EST
Description of problem:
Installation of RHEL4.7 X86_64 with full software package installed. This causes a tainted kernel with a /proc/sys/kernel/tainted value of 16. The error causes a INFO test job always fail for hardware certification. but PASSED on RHEL4.7 X86 with full software package installed.

The issue is similar to Bug 481690

Version-Release number of selected component (if applicable):
HTS version 5.2 release 20
RHEL4.7 x86_64 kernel-largesmp-2.6.9-78.EL

How reproducible:
Every time.


Steps to Reproduce:
1. Install RHEL4.7 x86_64 with full software package installed
2. Check contents of /proc/sys/kernel/tainted
3. Value is 16 (non-zero)
4. Run 'hts certify --test info' or any other test that includes INFO, INFO will
fail.

  
Actual results:
INFO fail with Tainted kernel.

Expected results:
Non-tainted kernel with INFO pass.

Additional info:
INFO test PASSED on RHEL4.7 X86 with full software package installed without tainted kernel
Comment 1 abel0301 2009-02-13 03:00:14 EST
Verified and Passed INFO testing on RHEL4.6 x86_64 (full software package installed) without tainted kernel
Comment 2 Rob Landry 2009-02-13 10:35:54 EST
A value of 16 most likely means your box suffered from an unknown MCE which means you'll need to check the system board logs to find out.  The typical cause is bad RAM but it isn't exclusive to this.
Comment 3 abel0301 2009-02-16 21:21:27 EST
This strange problem fixed with our stable firmware and thanks to Rob for your great information.

Note You need to log in before you can comment on or make changes to this bug.