Bug 485386 - Seamonkey is incompatible with the SUN Java plugin
Seamonkey is incompatible with the SUN Java plugin
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: seamonkey (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Martin Stransky
Ben Levenson
: Triaged
Depends On: 460417
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 03:26 EST by Radek Bíba
Modified: 2011-10-20 08:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 08:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2009-02-13 03:26:22 EST
Description of problem:
SSIA.

Version-Release number of selected component (if applicable):
seamonkey-1.0.9-35.el4.x86_64
java-1.6.0-sun-1.6.0.12-1jpp.3.el4.x86_64
java-1.6.0-sun-plugin-1.6.0.12-1jpp.3.el4.x86_64

How reproducible:
Always

Steps to Reproduce:
1. make sure the packages above are installed
2. launch seamonkey
3. visit a page with a java applet, e.g.
http://www.cs.ubc.ca/~harrison/Java/sorting-demo.html
  
Actual results:
Segmentation fault

Expected results:
Running java applet, or at least a decent error message.

Additional info:
This is a new problem, the 64bit SUN plugin didn't exist earlier. In fact, we haven't released it yet. But it works great with firefox, even out-of-the-box with the RPM above. It's just seamonkey that accepts it as a valid plugin (see about:plugins), but crashes when it attempts to use it.
Comment 1 Martin Stransky 2009-02-13 11:26:25 EST
Seamonkey 1.0.x and 1.1.x fails to exchange NPAPI callback table with the java plugin...2.0a works fine. Looks like some misconfiguration...
Comment 2 Martin Stransky 2009-02-16 09:37:52 EST
the 64-bit plugin ignores all old mozilla browsers (1.8.0 and 1.8.1), returns NPERR_INCOMPATIBLE_VERSION_ERROR from NP_Initialize().

We can cosider to hack the plugin interface or at least fix crash of the old seamonkey.
Comment 4 Martin Stransky 2010-03-09 09:20:14 EST
It will be fixed when Bug 460417 lands.
Comment 5 Radek Bíba 2010-07-26 04:15:37 EDT
Update:

java-1.6.0-sun-plugin-1.6.0.21-1jpp.1.el4 + seamonkey-1.0.9-61.el4 = no crash. Yay! Applets still don't work, but I guess that won't get better until Seamonkey is rebased. There's one thing that could be improved in the meantime, though: when a page with an applet is visited, a dialog pops up asking me if I want to download the appropriate plug-in for application/x-java-vm. When I click OK, seamonkey goes to http://www.propeller.com/plugins/jvm.html, which gives 404: Page not Found. That's not helpful.

FTR, we've just switched to libnpjp.so also in case of the 32-bit Sun java plugin.
Comment 6 Martin Stransky 2011-10-20 08:32:34 EDT
We're not going to fix in in seamonkey on RHEL4.

Note You need to log in before you can comment on or make changes to this bug.