Bug 485399 - During initial steps of install all IRQ's used are disabled (Disabling IRQ#) and installation hangs.
During initial steps of install all IRQ's used are disabled (Disabling IRQ#) ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 06:11 EST by gl.franceschin
Modified: 2009-12-18 02:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:54:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gl.franceschin 2009-02-13 06:11:23 EST
Description of problem:
I tried to install F10 on a Compaq Proliant 5000 with 2 Pentium Pro, 1152Mb ram, ATI chipset pci video card(RV100) (IRQ #10), 2 Compaq smart-2 array controllers(Firm.4.50)(IRQ #15 & #5, Embedded scsi controller (Sym 53c825)(IRQ #14), Sil0680 ATA raid controller(IRQ #11) and a Realtek Gigabit lan card(IRQ #9). I gave the normal kernel parameters for Proliant memory (memmap=exactmap memmap=640k@0 memmap=1151m@1m mem=1152m) and the install started:

Loading vmlinuz..................
Loading initrd.img.................(3 rows of dots)....ready
Probing EDD(edd=off to disable).......ok

(then lots of lines I could not catch till:)

Greetings.
anaconda installer init version 11.4.1.62 starting
mounting /proc filesystem... done
creating /dev filesystem... done
starting udev...done
mounting /dev/pts (unix98 pty) filesystem... done
trying to remount root filesystem read write... done
mounting /tmp as ramfs... done
Disabling IRQ #8
running install...
running /sbin/loader
Disabling IRQ #1
detecting hardware...
waiting for hardware to initialize...
Disabling IRQ #15
Disabling IRQ #14

after some time (about 2 minutes) I got the language choosing screen but no way to interract with it (tried the numlock key , Ctrl+Alt+Del and nothing happened).

I retried with:
1)irqpoll - no change.

2)noirqdebug - no change except for no messages of disabled IRQ's

3)nolapic - I reached this point:
(blue screen)
Running anaconda 11.4.1.62, the Fedora system installer - please wait...
22:25:24 Starting graphical installation...
mini-wm: Fatal IO error 11 (Resource temporarily unavailable) on Xserver :1.0.
anaconda: Fatal IO error 11 (Resource temporarily unavailable) on Xserver :1.0.
install exited abnormally [1/1]
disabling swap...
unmounting filesystem... etc.

I then tried:
1)F9 - machine hanged before graphical install.
2)F8 - Installation succesfull (Ferdora (2.6.23.1-42.fc8)) systemwas ok, but after yum update (Fedora (2.6.26.8.57.fc8)) at the reboot:

Red Hat nash version 6.0.19 starting
handlers:
[<c058ddd0>] (i8042_interrupt+0x0/0x1e9)
Disabling IRQ #1
irq 15: nobody cared (try booting with the "irqpoll" option)
handlers:
[<f885b213>] (do_ida_intr+0x0/0x290 [cpqarray])
Disabling IRQ #15
_    (system hanged)

I tried with the irqpoll option but no changes.

I searched in the release notes and noted the big changes from F8 and F9,F10. Some link with the problem?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2009-02-13 06:54:49 EST
huh? component udev? I think this is kernel!
Comment 2 Bug Zapper 2009-11-18 04:50:48 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-12-18 02:54:44 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.