Bug 485425 - 'module' object has not attribute 'file_system_type_get'
'module' object has not attribute 'file_system_type_get'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 09:53 EST by John Reiser
Modified: 2009-02-13 09:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 09:59:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-02-13 09:53:34 EST
Description of problem: anaconda aborts early during attempted install.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.17

How reproducible: always


Steps to Reproduce:
1. boot today's i386 boot.iso netinstall CD
2.
3.
  
Actual results: before switching to graphical mode, anaconda gets a traceback with message:
File "/usr/lib/anaconda/fsset.py", line 338 in __init__
   self.partedFileSystemType = parted.file_system_type_get("reiserfs")
AttributeError: 'module' object has no attribute 'file_system_type_get'


Expected results: no error; continue with install


Additional info:
Comment 1 Chris Lumens 2009-02-13 09:59:39 EST
Yes, this is because the new pyparted got built without a corresponding anaconda build.  It'll be fixed up in just a minute here when I rebuild anaconda.  Of course, there are likely to be lots of other problems here in the next couple days.

Note You need to log in before you can comment on or make changes to this bug.