Bug 485440 - Build of package has unavailable dependency
Build of package has unavailable dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 11:02 EST by Steve Snyder
Modified: 2009-09-25 11:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 11:06:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2009-02-13 11:02:17 EST
Description of problem:

When building the kdepim package ("rpmbuild --rebuild kdepim-4.2.0-2.fc10.src.rpm) on a fully updated Fedora 10 system, the build fails.  The failure is due to this dependency: libmal-devel >= 0.40.  This version of libmal-devel is not yet available from the Fedora repositories.  The latest available is v0.31.

Version-Release number of selected component (if applicable):

kdepim-4.2.0-2.fc10.src.rpm

How reproducible:

Always

Steps to Reproduce:
1. Run: rpmbuild --rebuild kdepim-4.2.0-2.fc10.src.rpm
2. Note complaint of unsatisfied dependency on package libmal-devel v0.40
3.
  
Actual results:

Failure to build the binary packages.

Expected results:

Source package dependencies should be available to satisfy requirements.

Additional info:
Comment 1 Rex Dieter 2009-02-13 11:23:37 EST
Looks mostly harmless at the moment, apparently kdepim doesn't actually use it.
Comment 2 Kevin Kofler 2009-02-13 11:26:56 EST
Looks like we missed this one because CMake checks for libmal, but it doesn't actually use it. Fun...

From branches/KDE/4.2/kdepim/kpilot/conduits/CMakeLists.txt:
###
#
# MAL seems to be broken, or the MAL API has changed somewhat
# since the last time that the conduit was compiled by the development
# team. Since we don't use the conduit it is disabled. 
#IF (MAL_FOUND)
#       MESSAGE(STATUS "MAL conduit will not be compiled, not ported yet.")
#       add_subdirectory(malconduit)
#ELSE (MAL_FOUND)
#       MESSAGE(STATUS "Couldn't find mal. Won't be able to build malconduit")
#ENDIF (MAL_FOUND)

So the BuildRequires is not actually needed. Try rpmbuild --rebuild --nodeps for now.

But we're pushing the new libmal (the one we used to build the updates) in the next push:
https://admin.fedoraproject.org/updates/libmal-0.44-1.fc10
Comment 3 Rex Dieter 2009-09-25 11:06:47 EDT
in the meantime libmal dep was removed in later versions of kdepim

Note You need to log in before you can comment on or make changes to this bug.