Bug 485449 - klipper revives old selection in evolution
klipper revives old selection in evolution
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 11:19 EST by Denys Vlasenko
Modified: 2009-02-20 12:13 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 12:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 571654 None None None Never

  None (edit)
Description Denys Vlasenko 2009-02-13 11:19:24 EST
Open a new mail window in Evolution.
Type some text.
Select and copy/paste small fragment of it.
Now deselect it, so that you don't have any selected text.

Select a text in any other window (I do it in konsole with mouse).

Got back to Evolution window.

If you paste (with mouse or by pressing Ctrl-V) EXACTLY on current text cursor position, it works correctly.

But if you move cursor first using cursor keys, and then paste text, it will paste wrong text - the old one, which you selected on step 3.


Looks like cursor movement with keyboard in Evolution somehow tricks klipper into thinking that Evolution re-selected old selected text.
Comment 1 Denys Vlasenko 2009-02-13 11:20:39 EST
The same does not seem to happen with other apps (tried with Firefox).

Versions: Fedora 9, Evolution 2.22.3.1

# rpm -q evolution
evolution-2.22.3.1-1.fc9.x86_64
Comment 2 Denys Vlasenko 2009-02-13 11:32:48 EST
More version info:

Klipper Version v0.9.7 Using KDE 4.1.4 (KDE 4.1.4)

# rpm -qa | grep kde | grep work
kdebase-workspace-libs-4.1.4-1.fc9.x86_64
kdebase-workspace-4.1.4-1.fc9.x86_64
Comment 3 Jaroslav Reznik 2009-02-13 11:42:02 EST
I can reproduce it even without Klipper. So I don't think it's Klipper's bug - it behaves correctly everywhere but Evolution.
Comment 4 Rex Dieter 2009-02-13 11:44:16 EST
reassigning for comment from the evolution folk...
Comment 5 Milan Crha 2009-02-13 12:31:50 EST
OK, actual trunk does that as well. it'll come to gtkhtml probably, but will see. Nonetheless, moving it upstream, there is no need to have (not-written-yet) fix in Fedora only. See upstream bug [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=571654

Note You need to log in before you can comment on or make changes to this bug.