Bug 485501 - Unable to launch X with radeon
Unable to launch X with radeon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 485838 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-02-13 14:29 EST by Jesse Keating
Modified: 2013-01-09 22:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 04:02:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.log of X failing to find screens on my radeon x1950 (35.90 KB, text/plain)
2009-02-19 03:06 EST, Hans de Goede
no flags Details
xorg.log of exact same X-start, but with logfile on usb-stick, this succeeds!! ?? (47.30 KB, text/plain)
2009-02-19 03:07 EST, Hans de Goede
no flags Details
xorg.log of trying to start X with radeon modprobed first. (7.63 KB, text/plain)
2009-02-19 03:29 EST, Hans de Goede
no flags Details

  None (edit)
Description Jesse Keating 2009-02-13 14:29:23 EST
(EE) RADEON: Failed to laod module fb (module does not exist, 0)
Comment 1 Chris Lumens 2009-02-16 11:02:01 EST
fbdev_drv.so definitely exists on the install media.  Assuming this is reproducable, can you please attach /tmp/X.log?
Comment 2 Chris Lumens 2009-02-17 09:59:15 EST
*** Bug 485838 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-02-17 09:59:59 EST
Taking out of NEEDINFO.
Comment 4 Chris Lumens 2009-02-17 10:12:41 EST
Sorry, it's not fbdev_drv.so that's the problem.  It's libfb.so.  And that still exists on this machine I've got booted up, so I wonder what the deal is.
Comment 5 Hans de Goede 2009-02-19 03:05:52 EST
I can reproduce this. With some trickery I've finally managed to get a full xorg.log of the failure. Strange enough if I make xorg log to a mounted usb-stick, it no longer fails to find the screens, so there seems to be some timing issue involved here.

Will attach logs.
Comment 6 Hans de Goede 2009-02-19 03:06:43 EST
Created attachment 332507 [details]
xorg.log of X failing to find screens on my radeon x1950
Comment 7 Hans de Goede 2009-02-19 03:07:27 EST
Created attachment 332508 [details]
xorg.log of exact same X-start, but with logfile on usb-stick, this succeeds!! ??
Comment 8 Hans de Goede 2009-02-19 03:09:08 EST
Note: running with "nomodeset" makes the problem go away.
Comment 9 Hans de Goede 2009-02-19 03:11:14 EST
Diffing the 2 logs the following stands out:

@@ -725,21 +725,263 @@
 (++) RADEON(0): DPI set to (96, 96)
 (II) Loading sub module "fb"
 (II) LoadModule: "fb"
-(WW) Warning, couldn't open module fb
-(II) UnloadModule: "fb"
-(EE) RADEON: Failed to load module "fb" (module does not exist, 0)
-(II) UnloadModule: "radeon"
-(II) UnloadModule: "int10" 
-(II) Unloading /usr/lib/xorg/modules//libint10.so
-(II) UnloadModule: "vgahw"
-(II) Unloading /usr/lib/xorg/modules//libvgahw.so
-(EE) Screen(s) found, but none have a usable configuration.

<snip>
+(II) Loading /usr/lib/xorg/modules//libfb.so
+(II) Module fb: vendor="X.Org Foundation"
+       compiled for 1.5.99.902, module version = 1.0.0
+       ABI class: X.Org ANSI C Emulation, version 0.4
+(==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)

So in one case it is finding / loading the fb module and in the other case it is not ???
Comment 10 Hans de Goede 2009-02-19 03:28:28 EST
I've been discussing this with airlied on irc, the problem is that radeon is getting loading by Xorg instead of earlier by udev, triggering a race.

However I've just done a test where I first manually modprobed radeon and then I get a different error. Attaching log of this attempt.
Comment 11 Hans de Goede 2009-02-19 03:29:10 EST
Created attachment 332511 [details]
xorg.log of trying to start X with radeon modprobed first.
Comment 12 Hans de Goede 2009-02-19 03:57:19 EST
Comment on attachment 332511 [details]
xorg.log of trying to start X with radeon modprobed first.

Ok, the third time I screwed up, I didn't have /sys mounted making X unhappy.

With that fixed, and modprobing radeon befor starting X things work.

So I'm reassignign this to kernel (radeon is missing module ID's) and xlosing (airlied just fixed the missing module ID's).

Note You need to log in before you can comment on or make changes to this bug.