Bug 485515 - Leverage information for a server submission does not stick between saves
Leverage information for a server submission does not stick between saves
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: XINSUN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 16:03 EST by Gregory Feiner
Modified: 2009-02-19 22:30 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.3(hwcert-3.2rh-20090219.0)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 22:29:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Feiner 2009-02-13 16:03:08 EST
Description of problem:
When a server submission is created, the reviewer creates a test plan that will include a number options (NICS, Storage controllers, etc) that have to be tested.  At HP, we leverage 99% of the options for a given server so we go through and enter leverage test IDs for said options.  I have discovered that it is easy to accidentally erase all entered leverage information due to the default behavior of the website.

For example: submission/BZ #485106.  This submission has many options that will be leveraged. Say I want to enter XXXX for the leverage ID for the Smart Array E200.  First you have to change the drop-down list from the default setting of "---------" to "Leverage".  Then I enter the Test ID number and click the Save button.  After clicking the Save button, the drop down list for the Smart Array E200 will default back to "----------".  If I click the Save button a 2nd time or enter a leverage ID for another option and then click the Save button, then the information I entered for the Smart Array E200 will be deleted.  This happens because the selection for the drop-down list defaults back to "-------" after entering the information and clicking the Save button.

I suggest the following change be made:
Once a user enters leverage information for an option, do not reset the drop down list back to "-------" after the Save button is clicked.  If a user enters leverage information for an option, make the drop-down list stay at "Leverage" unless the user changes it manually.

As it stands now, a user has two options:
1. Enter all leverage information at the same time then click the save button once.  This assumes the user has all the information in a single setting which isn't always the case in the situation where there are many options to enter leverage information for.

2. Enter the leverage information in stages, but be sure to go back and set the drop-down list for each option that already has leverage information entered  back to the "Leverage" selection before clicking the Save button after having entered the information for the additional items.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
read the example I gave earlier in this description.
  
Actual results: information about leverage information can be inadvertantly erased, driving me to drink. :)


Expected results:
Would like leverage information to "stick" between clicks of the Save button.


Additional info:
Comment 1 David Aquilina 2009-02-18 03:05:10 EST
GSS believes this should be a high-priority catalog bug, flagging as such.
Comment 4 David Aquilina 2009-02-19 11:19:01 EST
Greg, 

What browser are you using to interact with the hardware catalog? The hwcert team wasn't able to see this behavior with Firefox, however they were able to see it with Konqueror. 

They believe they've found what's causing the problem and are working on a fix, but in the meantime using Firefox will probably work around this. 

Thanks, 
David
Comment 5 Gregory Feiner 2009-02-19 11:41:27 EST
David,

I'm using IE7.  That tip about Firefox is good to know. I'll use it for my BZ/HW cert work.

Note You need to log in before you can comment on or make changes to this bug.