Bug 485554 - Allow local user USB access to (Garmin) GPS devices (via PolicyKit)
Allow local user USB access to (Garmin) GPS devices (via PolicyKit)
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-14 06:32 EST by Hans Ulrich Niedermann
Modified: 2014-11-09 14:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
add org.freedesktop.hal.device-access.gps action (797 bytes, patch)
2009-02-14 06:32 EST, Hans Ulrich Niedermann
no flags Details | Diff
/etc/hal/fdi/information/10-garmin-gps.fdi (535 bytes, text/plain)
2009-02-14 06:33 EST, Hans Ulrich Niedermann
no flags Details
/etc/hal/fdi/policy/10-garmin-gps.fdi (469 bytes, text/plain)
2009-02-14 06:34 EST, Hans Ulrich Niedermann
no flags Details

  None (edit)
Description Hans Ulrich Niedermann 2009-02-14 06:32:16 EST
Created attachment 331911 [details]
add org.freedesktop.hal.device-access.gps action

Description of problem:

  When I plug in a (e.g. Garmin) GPS device via USB cable,
  only root has access to it. Standard software to interface
  with the GPS device thus does not work for the logged in

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Log in as user
2. Plug in Garmin USB device
3. Try to download your tracks with
   $ gpsbabel -t -i garmin -f usb: -o gpx -F tracks-$(date).gpx
Actual results:

  Claim interfaced failed: could not claim interface 0: Operation not permitted

Expected results:

  empty program output, signifying successful download of the tracks.

Additional info:

  I am going attach what I used to solve the issue here. That might
  not be fit for distribution with the hal package, but may be of
  use for other users or to illustrate the issue.
Comment 1 Hans Ulrich Niedermann 2009-02-14 06:33:33 EST
Created attachment 331912 [details]
Comment 2 Hans Ulrich Niedermann 2009-02-14 06:34:25 EST
Created attachment 331913 [details]
Comment 3 Hans Ulrich Niedermann 2009-02-14 06:35:26 EST
Comment on attachment 331911 [details]
add org.freedesktop.hal.device-access.gps action

This is just a copy of the existing PDA policy, with "PDA" being substituted
by "GPS".
Comment 4 Scott Glaser 2009-09-09 09:08:23 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

Fedora Bugzappers volunteer triage team
Comment 5 Bug Zapper 2009-11-18 06:06:29 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 6 Bug Zapper 2009-12-18 02:55:04 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 7 Hans Ulrich Niedermann 2014-11-09 14:49:15 EST
Closing the NEEDINFO part on this ancient WONTFIX to stop bugzilla from bothering me about the NEEDINFO on a weekly basis.

Note You need to log in before you can comment on or make changes to this bug.