Bug 485562 - Chinese fonts is used for Japanese desktop after vlgothic-fonts-20090204-2.fc10 installed
Summary: Chinese fonts is used for Japanese desktop after vlgothic-fonts-20090204-2.fc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cjkunifonts
Version: 10
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-14 13:44 UTC by Yuta Kitamura
Modified: 2009-05-20 05:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 475743
Environment:
Last Closed: 2009-05-20 05:09:48 UTC
Type: ---


Attachments (Terms of Use)
Rendering comparison (84.09 KB, image/png)
2009-02-14 13:44 UTC, Yuta Kitamura
no flags Details
Test case after cjkunifonts-uming package updated (37.64 KB, image/png)
2009-02-27 08:12 UTC, Yuta Kitamura
no flags Details

Description Yuta Kitamura 2009-02-14 13:44:28 UTC
Created attachment 331920 [details]
Rendering comparison

Description of problem:
After installing vlgothic-fonts-20090204-2.fc10.noarch, some Japanese
characters are incorrectly rendered with a different font (apparently
a Chinese one). More specifically, when an ASCII alphabetical character is
followed some Japanese characters (Japanese punctuations for example),
the followed characters are not rendered with the VLGothic font, but
with a Chinese one.

This does not happen with VLGothic-fonts-20081029-1.fc10.noarch and before.
See attached image for comparison. gedit is used for capturing.
The "monospace" font and the "sans-serif" font causes this problem.

Version-Release number of selected component (if applicable):
vlgothic-fonts-20090204-2.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Display a Japanese text with "monospace" or "sans-serif" font.
  
Actual results:
Some characters are rendered with a Chinese font.

Expected results:
Characters should be rendered with the VLGothic font.

Additional info:

Comment 1 Akira TAGOH 2009-02-16 02:04:01 UTC
Better reassigning to cjkunifonts.

Comment 2 Jens Petersen 2009-02-16 03:02:49 UTC
Can you post the output of:

rpm -qa \*fonts\* | sort

It would be hopeful if you can narrow down which font package is causing the problem.
It might be baekmuk-ttf for example? (see also end of bug 475743 comment 32)

Comment 4 Caius Chance 2009-02-16 15:55:53 UTC
This one might be duplicated to bug #475743.

Comment 5 Ignacio Vazquez-Abrams 2009-02-24 06:48:10 UTC
The issue is 64-ttf-arphic-uming.conf. After renaming it to 67-... various glyphs came up as gothic. This file probably needs to be split into a high-priority serif portion, and a low-priority sans portion.

Comment 6 Jens Petersen 2009-02-24 07:09:38 UTC
Perhaps you can test with the cjkuni-*fonts packages in rawhide and see if that works better for you?

They already have some fontconfig changes included.

Comment 7 Ignacio Vazquez-Abrams 2009-02-24 07:47:11 UTC
Installing the fonts from Rawhide did help.

Comment 9 Fedora Update System 2009-02-25 04:29:38 UTC
cjkunifonts-0.2.20080216.1-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cjkunifonts-0.2.20080216.1-11.fc10

Comment 10 Caius Chance 2009-02-25 05:13:43 UTC
Hi Yuta, could you kindly provide the test case you mentioned in comment #1 please? Thanks.

Comment 11 Yuta Kitamura 2009-02-27 08:12:27 UTC
Created attachment 333444 [details]
Test case after cjkunifonts-uming package updated

OK, here's a screenshot. It seems that everything is working flawlessly.

Just FYI, I've updated only cjkunifonts-uming package, because it's the only
package of cjkunifonts-* series installed in my box.

Comment 12 Jens Petersen 2009-03-02 01:47:45 UTC
Thanks for testing.

Comment 13 Fedora Update System 2009-03-13 18:42:10 UTC
cjkunifonts-0.2.20080216.1-11.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.