Bug 485568 - Starting a KVM virtual machine does not always succeed
Starting a KVM virtual machine does not always succeed
Status: CLOSED DUPLICATE of bug 484649
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-14 11:21 EST by Jasper Capel
Modified: 2009-02-16 19:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 19:54:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jasper Capel 2009-02-14 11:21:05 EST
Description of problem:
Starting a KVM virtual machine does not always succeed

Version-Release number of selected component (if applicable):
kvm-83-5.fc11.x86_64
libvirt-0.6.0-3.fc11.x86_64
libvirt-python-0.6.0-3.fc11.x86_64
qemu-0.9.1-12.fc11.x86_64


Steps to Reproduce:

1. Try to create/start a virtual machine for kvm-qemu using virt-manager, or through another program that uses the libvirt api (for example: koan)
  
Actual results:

The virtual machine is started, after giving it a few attempts (this seems to be quite random, sometimes it just works, at other times it only works after pressing run in virt-manager often enough).

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 498, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 508, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: 


Expected results:
The virtual machine starts, or at least does not start, while a human-understandable error message is displayed (for example: not enough memory).

Additional info:
I'm actually not sure if this is a KVM or libvirt bug or some mistake on my end.
Comment 1 Glauber Costa 2009-02-16 09:08:32 EST
do you have anything in logs?

dmesg and libvirt logs at /var/log/libvirt are appreciated (specially the later)
Comment 2 Jasper Capel 2009-02-16 12:25:42 EST
For a failed attempt, dmesg shows:

device vnet0 entered promiscuous mode
virbr0: topology change detected, propagating
virbr0: port 1(vnet0) entering forwarding state
virbr0: port 1(vnet0) entering disabled state
device vnet0 left promiscuous mode
virbr0: port 1(vnet0) entering disabled state


/var/log/libvirt/qemu/lenny.log (where lenny is the name of my VM) shows:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name lenny -uuid d6649746-f5bf-bc08-1b35-9515ed70ed04 -monitor pty -pidfile /var/run/libvirt/qemu//lenny.pid -boot c -drive file=,if=ide,media=cdrom,index=2 -drive file=/data/VMWARE/lenny-disk0,if=virtio,index=0,boot=on -net nic,macaddr=54:52:00:45:e6:e3,vlan=0,model=virtio -net tap,fd=17,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-us

I don't think these are particularly useful, could I somehow raise the log level a bit?
Comment 3 Jasper Capel 2009-02-16 14:06:35 EST
I got some more info, although probably still not very helpful (after starting libvirtd, the VM started at the 5th attempt):

[root@farnsworth ~]# libvirtd --verbose
20:02:54.452: info : Received unexpected signal 17
20:02:54.452: info : Received unexpected signal 17
20:02:54.453: info : Received unexpected signal 17
20:03:06.309: info : Checking PID 23388 running as 500
20:03:06.347: info : Policy allowed action org.libvirt.unix.manage from pid 23388, uid 500, result yes
20:03:06.348: info : Received unexpected signal 17
20:03:12.835: info : Received unexpected signal 17
20:03:12.837: info : Enabling IFF_VNET_HDR
20:03:12.918: info : Received unexpected signal 17
20:03:13.018: error : internal error unable to start guest:
libvir: QEMU error : internal error unable to start guest:
Shutting down VM 'lenny'
20:03:26.579: info : Enabling IFF_VNET_HDR
20:03:26.585: info : Received unexpected signal 17
20:03:26.637: info : Received unexpected signal 17
20:03:26.638: error : internal error unable to start guest:
libvir: QEMU error : internal error unable to start guest:
Shutting down VM 'lenny'
20:03:30.649: info : Received unexpected signal 17
20:03:30.650: info : Enabling IFF_VNET_HDR
20:03:30.692: error : internal error unable to start guest:
libvir: QEMU error : internal error unable to start guest:
Shutting down VM 'lenny'
20:03:30.693: info : Received unexpected signal 17
20:03:33.220: info : Received unexpected signal 17
20:03:33.222: info : Enabling IFF_VNET_HDR
20:03:33.276: info : Received unexpected signal 17
20:03:33.277: error : internal error unable to start guest:
libvir: QEMU error : internal error unable to start guest:
Shutting down VM 'lenny'
20:03:36.603: info : Received unexpected signal 17
20:03:36.606: info : Enabling IFF_VNET_HDR
20:03:36.630: info : Received unexpected signal 17

^ And here it's running.
Comment 4 Mark McLoughlin 2009-02-16 19:54:01 EST
Thanks for the report, it looks like a dup of an already reported bug with 0.6.0

*** This bug has been marked as a duplicate of bug 484649 ***

Note You need to log in before you can comment on or make changes to this bug.