Bug 485585 - Package should be a dependency of Electronics apps
Package should be a dependency of Electronics apps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: electronics-menu (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-14 17:14 EST by Steve Snyder
Modified: 2009-03-07 05:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 05:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2009-02-14 17:14:52 EST
Description of problem:

On a fully-updated Fedora 10 system, I found that I had a half-dozen apps in KDE's "Lost & Found" folder, all from the Electronics group.  I was correctly advised that this was due to not having the electronics-menu package installed.  My request: if a user has a graphical desktop installed, and applications from a given group, then the desktop menu package for that group should be installed as well.

Version-Release number of selected component (if applicable):

1.0-2.fc10

How reproducible:

Unknown

Steps to Reproduce:
1. Do full Fedora 10/x86_64 install
2. Apply all available updates for 2 months
3. Notice application in the KDE "Lost & Found" folder
  
Actual results:

Applications from Electronics group placed in "Lost & Found" folder

Expected results:

Install applications from the Electronics group should be in the Electronics folder by default.

Additional info:

As an aside: I don't think that Electronic should be a top-level menu, on the same level as System or Internet.  Maybe it should be beneath "Science & Math"?
Comment 1 Chitlesh GOORAH 2009-02-14 18:11:31 EST
(In reply to comment #0)
> Description of problem:
> 
> On a fully-updated Fedora 10 system, I found that I had a half-dozen apps in
> KDE's "Lost & Found" folder, all from the Electronics group.  I was correctly
> advised that this was due to not having the electronics-menu package installed.
>  My request: if a user has a graphical desktop installed, and applications from
> a given group, then the desktop menu package for that group should be installed
> as well.
> 

Can you please give a list of all the electronic software that are not in Electronic menu ?
for each one of them you should give me its

rpm -q ELECTRONICSOFTWARE

Currently all FEL packages maintained by me requires electronics-menu.


> 
> Additional info:
> 
> As an aside: I don't think that Electronic should be a top-level menu, on the
> same level as System or Internet.  Maybe it should be beneath "Science & Math"?

Well "Science & Math" is only kde  specific. Software that are used to design chips are not science software but engineering. Here I would like to precise that electronics engineering application are not for educational purposes but real life engineering tools.


I run KDE4.2 I don't experience this issue.
Comment 2 Steve Snyder 2009-02-14 18:24:30 EST
This list mirrors the apps I saw in L&F prior to explicitly installing the electronic-menu package:

$ grep -l Electronics /usr/share/applications/*.desktop
/usr/share/applications/fedora-geda-gattrib.desktop
/usr/share/applications/fedora-geda-gschem.desktop
/usr/share/applications/fedora-gerbv.desktop
/usr/share/applications/fedora-LabPlot.desktop
/usr/share/applications/fedora-pcb.desktop
/usr/share/applications/fedora-piklab.desktop
/usr/share/applications/fedora-toped.desktop

Some background: I did a clean install from the Fedora 10/x86_64 DVD.  I opted for everything on the DVD other than the clustering tools and the non-English language packages.  Since that installation I have installed several dozen *-devel packages and applied all F10 updates as they were released.  I noticed the apps in L&F while checking out the new KDE 4.2.0 changes, but those entries may have have been there for weeks or months or even from the initial installation.

Thanks for the quick response.
Comment 3 Chitlesh GOORAH 2009-03-07 05:53:53 EST
Packages affected were gerbv, geda-gattrib and geda-gschem. All of them have been committed to rawhide.

Note You need to log in before you can comment on or make changes to this bug.