Bug 485602 - DNS "disappear" when using networkmanager
DNS "disappear" when using networkmanager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 02:38 EST by Whistler
Modified: 2009-02-15 09:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 09:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Whistler 2009-02-15 02:38:48 EST
Description of problem:
When letting NetworkManager to manage the network connection, the manually set DNS servers tends to "disappear" after a reconnecting.


Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Always

Steps to Reproduce:
1.Set up a network connection with system-config-network, manually set some DNS servers, and enable NetworkManager.
2.Disconnect & reconnect the connection.

Actual results:
the DNS servers are "disappeared".

Expected results:
the DNS servers should be keep intact.
Comment 1 Dan Williams 2009-02-15 09:12:30 EST
The manually set DNS servers actually need to be placed into the ifcfg files directly, because /etc/resolv.conf can change depending on what you're connected to.  Thus /etc/resolv.conf cannot be the sole source of DNS information.

If you're using ifcfg-based connections, add the DNS servers directly to your ifcfg files (eg DNS1=4.2.2.1 and DNS2=4.2.2.2 for example).

If you're using user connections, you can add them in the connection editor in the IPv4 tab.

Note You need to log in before you can comment on or make changes to this bug.