Bug 485610 - crash and/or skip special characters on auto-typing
crash and/or skip special characters on auto-typing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: keepassx (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
http://www.keepassx.org/changelog
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 04:48 EST by bee
Modified: 2009-03-05 11:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.3.4-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 11:28:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bee 2009-02-15 04:48:56 EST
Description of problem:
crash and/or skip special characters on auto-typing.

Version-Release number of selected component (if applicable):
Keepassx 0.3.3 (2008-08-11)

How reproducible:
Run the auto-typing with an email address as username (like "honey@bee.net").


Steps to Reproduce:
1. Username: set any email address (because "@" is a special char)
2. Ctrl+V (auto-typing)
3. it'll skip to type "@" or crash


Expected results:
to work properly!!!!! 
that was simple!!!


Additional info:
http://www.keepassx.org/changelog
0.3.4 (2008-11-09)
    * fixed crash when auto-typing special characters (Bug #2111588)
    * only allow plain text in comment 


**************************
**************************
**************************
IF YOU UPDATE THE RPM TO THE LAST VERSION OF KEEPASSX, IT'LL BE SOLVED!! (looks like!!)
**************************
**************************
**************************
Comment 1 Aurelien Bompard 2009-02-16 02:18:14 EST
For some reason I wasn't notified of the new release of KeepassX.
I'll update it ASAP. Thanks for reporting.
Comment 2 Fedora Update System 2009-03-05 11:28:16 EST
keepassx-0.3.4-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.