Bug 485639 - F11 Upgrade path problem
F11 Upgrade path problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tex-fonts-hebrew (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-15 13:51 EST by Nicolas Mailhot
Modified: 2009-07-23 15:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.1-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-02-15 13:51:08 EST
1. tex-fonts-hebrew-0.1-10.fc11.noarch does not obsolete properly  tetex-fonts-hebrew-0.1-9.fc10.noarch, resulting in a broken F10 → F11 upgrade path

2. tex-fonts-hebrew-0.1-10.fc11.noarch depends on the culmus compat package. Don't do that, it's a compat package (ie it will go away, breaking your deps), depend on the actual font packages you need instead
Comment 1 Bug Zapper 2009-06-09 07:24:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2009-07-22 15:23:10 EDT
tex-fonts-hebrew-0.1-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tex-fonts-hebrew-0.1-12.fc11
Comment 3 Matan Ziv-Av 2009-07-22 16:09:57 EDT
There is an install problem - the package conflicts with tetex-fonts-hebrew, so I could only install it after removing tetex-fonts-hebrew.
(I had no problem on the F10->F11 upgrade).
Comment 4 Dan Kenigsberg 2009-07-23 02:53:19 EDT
Matan, would you be more specific? What tetex-fonts-hebrew version did you have installed? How did installation of tex-fonts-hebrew-0.1-12.fc11 ?
Comment 5 Matan Ziv-Av 2009-07-23 06:50:05 EDT
I had tetex-fonts-hebrew-0.1-11.fc11.noarch which was (probably) installed by a yum upgrade from F10 to F11.

I tried to install the test version of tex-fonts-hebrew by:

rpm -i http://admin.fedoraproject.org/updates/tex-fonts-hebrew-0.1-12.fc11

This failed, claiming that the *david* files conflict with the files from tetex-fonts-hebrew (this is from memmory, so it might have complained on other files as well.) After removing tetex-fonts-hebrew with rpm -e the install of tex-fonts-hebrew worked fine.
Comment 6 Fedora Update System 2009-07-23 15:02:53 EDT
tex-fonts-hebrew-0.1-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.