Bug 48564 - Cannot install Redhat 7.1 unto a RAID volume on an ICP Raid card in a Dell 4400
Cannot install Redhat 7.1 unto a RAID volume on an ICP Raid card in a Dell 4400
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-07-10 20:15 EDT by orden smith
Modified: 2007-03-26 23:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-18 12:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description orden smith 2001-07-10 20:15:21 EDT
Description of Problem:
FAILURE to install REdhat 7.1 on an ICP RAID volume:
The Dell 4400 has only a SCSI CD ROM drive. When the system is booted from 
the RH7.1 CD and "linux dd" entered from the "boot:" prompt, an ICP driver 
diskette is inserted and the driver read by the installer(RH7.1). Upon 
completion of the driver extraction from the diskette, RH7.1 installer 
does not provide the option to locate the RH7.1 install files from the 
SCSI CD-ROM. Only the "Hard Drive" option is given. As a result, the 
installation of RH7.1 cannot continue unto the ICP RAID volume. This 
procedure worked for RH7.0

How Reproducible: Very reproducible.

Steps to Reproduce:
1. Remove all SCSI disks from the Dell 4400 server. Install an ICP Raid 
card in a PCI slot. Connect 8 drives(scsi) to the ICP port.
2. Insert the RH7.1 disk in the SCSI CD that comes with the Dell 4400.
3. It boots. At tyhe Linux "boot:" prompt, type "linux dd".
4. Follow the instructions and load a diskette with the ICP Linux gdth 

Actual Results:
After loading the gdth driver, the installer returns and present only 
a "Hard Disk" as the optiuon to locate the Linux source files. It does not 
autoload the Adaptec SCSI dr ivers for the CD-ROM. At a later step, there 
are options to load drivers for hard disk but not for SCSI CD-ROM. 
Manually selecting and loading the aic7xxx driver detects the CD-ROM but 
does not present it as an option.

Expected Results:
Expected both " SCSI CD-ROM" and "Hard Disk as options to locate the rest 
of the 7.1 installation files.

Additional Information:
Comment 1 Matt Wilson 2001-07-12 10:48:57 EDT
the CD-ROM is attached to an Adaptec SCSI card?
Comment 2 Boji Tony Kannanthanam 2001-07-12 17:16:02 EDT
Yes the CDROM is attached to the Adaptec card. The CDROM would be accessible if 
the Installer autoloaded the adaptec driver or gave a manual option to do 
so.... Actually it does give a manual option but as part of "Hard disk" option 
to locate the Installation files and not as a "CDROM" option. As a result when 
I manually select the adaptec driver; though the driver gets loaded and the 
CDROM is detected (I checked the system log by hitting <ALT-F4> during 
installation) ; it is not presented as a device from which to obtain the 
installation files. Maybe at that point the installer should updated its list 
of both Hard Disks and CDROM devices (instead of just the hard disk ?)present 
in the system.
Comment 3 Matt Wilson 2001-07-13 02:24:52 EDT
Please boot with "linux noprobe dd" then insert the aic7xxx driver, then your
gpt driver.
Comment 4 orden smith 2001-07-13 16:46:01 EDT
I tried the option 'linux noprobe dd' and I was able to select the SCSI driver 
and hence found the CD-ROM. I was able to continue the installation.

QU: Are these install option documented anywhere? (linux dd, linux probe dd, 
linux noprobe dd, and any other that might be relevant)
Comment 5 Brent Fox 2001-07-18 12:10:41 EDT
The driver disk options are documented at:

Other boot options are documented at:

As far as I know, the probe/noprobe options are not documented anywhere.

Note You need to log in before you can comment on or make changes to this bug.