Bug 485662 - installation: custom: packages: Everything should be first, not last
installation: custom: packages: Everything should be first, not last
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 21:39 EST by Nick Levinson
Modified: 2009-06-03 03:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 10:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Levinson 2009-02-15 21:39:32 EST
Description of problem: "Everything" option comes after separate packages listing. "Everything" should be first or close to it, visible without scrolling.


Version-Release number of selected component (if applicable): Unknown.


How reproducible:


Steps to Reproduce:
1. Begin installation.
2. Choose custom installation.
3. Proceed to list of packages that may be selected.
  
Actual results: "Everything" is near the bottom.


Expected results: "Everything" should be near the top.


Additional info: This is for improving the installation program, at least as I found it in Fedora Core 4. I'm not suggesting a retroactive change, but only for new Cores.

Why the option to install everything should be at the top of the list of many packages:
--- It takes a long time to read through all the packages and review the details of every single package. Only after picking out many packages and working on the details do we notice that Everything is an option.
--- Everything includes some things not listed separately.
--- If games are omitted, as I recall from the first installation, the installation fails. Perhaps some file specified in a dependency is missing from a non-game program environment. I don't like games but have to install and keep them to make sure other things I do use work. For the strongest likelihood that all dependencies will be met, I choose Everything, which thus may as well be at the top. Since you can't pretest every selective combination users might choose, users are better off choosing Everything, storage and RAM permitting.

(I entered the platform for this report as i686. I hope that's correct; it's a Pentium 4 laptop.)

Thanks.

-- 
Nick
Comment 1 Chris Lumens 2009-02-16 10:06:14 EST
This bug is no longer relevant - the package selection UI hasn't looked like this for years, and we don't even have an Everything option anymore.  Please try this with a more recent release (like F10) and let us know if you are still experiencing problems with this UI.
Comment 2 Nick Levinson 2009-06-03 03:26:17 EDT
I just installed Fedora 10. The installation routine is fundamentally akin in its user interface and its underlying structure to that for Fedora Core 4. But if the Everything choice is not at the beginning or at the end or elsewhere we have no Everything and that is a problem, so I proposed an alternative at Bug 503880.

Thanks.

-- 
Nick

Note You need to log in before you can comment on or make changes to this bug.