Bug 485711 - The ALTERNATE-DISPLAY Mode of top is broken in Fedora.
The ALTERNATE-DISPLAY Mode of top is broken in Fedora.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 09:52 EST by iolaci
Modified: 2009-03-30 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 06:31:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a screenshot (322.71 KB, image/png)
2009-02-24 05:29 EST, Daniel Novotny
no flags Details

  None (edit)
Description iolaci 2009-02-16 09:52:20 EST
Description of problem:
The ALTERNATE-DISPLAY Mode of top is broken in Fedora. The problem has been tested and verified on Fedora 7,8 and 9.

If you start top you can reach the ALTERNATE-DISPLAY Mode with SHIFT+a. This works on a debian and an ubuntu installation of the same hosts / same screens but if I do this on Fedora the seperate fields start to go into each other, some parts totally disappear on the screen and the whole view is unusable.

So this whole function doesn't work at all. It has been tested now on several machines running fedora 7-9. The same thing works on other distributions on the same hosts so I think this is a fedora related problem.


Version-Release number of selected component (if applicable):
procps-3.2.7-20.fc9.i386
and:
procps-3.2.7-17.fc8.i386,
procps-3.2.7-16.1.fc7.i386

How reproducible:
Everytime.

Steps to Reproduce:
1. Start top  
2. press SHIFT+a
  

Expected results:
Four seperate fields. At the top the usual top-header with Loardaverage and thing like that, then different fields sorting processes after different categories.


Additional info:
Comment 1 Daniel Novotny 2009-02-24 05:29:32 EST
Created attachment 333020 [details]
a screenshot

this seems to work for me - see the screenshot (F9)
Comment 2 lexual 2009-03-03 18:50:47 EST
Can't reproduce here with F10.
Can you still reproduce this?
If so, can you please attach a screenshot.
Comment 3 Daniel Novotny 2009-03-30 06:31:08 EDT
closing WORKSFORME. if the problem persists, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.