Bug 485771 - 6.0.76 breaks root=/dev/VG/Vol
6.0.76 breaks root=/dev/VG/Vol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 13:44 EST by Pete Zaitcev
Modified: 2009-02-16 15:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:54:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2009-02-16 13:44:52 EST
Description of problem:

After an update, newly installed kernels stopped booting due to broken
initrd; root volume cannot be found. This regressed from 6.0.75.

Version-Release number of selected component (if applicable):

6.0.76-1.fc11

How reproducible:

100%, given the configuration

Steps to Reproduce:

1. Install Fedora with root on a logical volume.
2. Install mkinitrd 6.0.76 or later.
3. Run mkinitrd
  
Actual results:

initrd-xxxxx.img fails to find root volume

Expected results:

Bootable kernel

Additional info:

When running mkinitrd, the following messages are seen:

[root@niphredil linux-2.6.29-rc5-tip]# mkinitrd /boot/initrd-2.6.29-rc5-tip.img 2.6.29-rc5-tip
WARNING: /sys/block/dm-0 is a not a block sysfs path, skipping
WARNING: /sys/block/dm-1 is a not a block sysfs path, skipping
[root@niphredil linux-2.6.29-rc5-tip]# 

Pay no mind to the self-built kernel, it's exactly the same with any
kernel (first noticed with kernel-2.6.29-0.112.rc4.git3.fc11.x86_64).

The root argument:

[zaitcev@niphredil tmp]$ cat /proc/cmdline 
ro root=/dev/N1/Fedora selinux=0 libusual.bias="ub"
[zaitcev@niphredil tmp]$ 

Forcing 6.0.75 with  rpm -U --oldpackage  fixes the problem.

The changelog:

* Wed Feb 04 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.76-1
- Fix configuration of network interfaces for network boot (#481078)
- Fix iscsi chap password being seen as ********
- Handle lv root specified as /dev/dm-X properly (#471729)
- Initial commit of EXTLINUX (no menu) support
- Do not call dm_resolve_name on dmraidsets names, sometimes it fails, and
  it is not necessary, this fixes the dmraid boot failure seen on
  some systems (#476818)
- Make nash mount support relatime (#296361)
- FIX: nash unable to find dm devs by uuid or label (#480667)

At the face of it, it's either bug 471729 or bug 480667.

Also! The bug 483423 has similar symptoms, but it's for a different
release and seems to occur in F10 GA. So, probably not the same.
Please don't dup until Hans reproduces this bug and finds the issue.
Comment 1 Hans de Goede 2009-02-16 13:58:04 EST
Hi Pete,

Are you on irc? Anyways can you do an ls -l /sys/block ?
What you see there should be symlinks, unless you've got "deprecated sysfs" (or something similar) enabled in your kernel config, in which case yes the new mkinitrd will break.

I think this is your problem, because mkinitrd does a readlink, so normally the message should never show the /sys/block/dm-0, unless that is not a symlink, which means you're using the deprecated sysfs layout option.
Comment 2 Hans de Goede 2009-02-16 13:58:39 EST
p.s. I'm hansg on both freenode and RHAT irc
Comment 3 Pete Zaitcev 2009-02-16 15:14:10 EST
Thanks a lot, I'll verify and close as NOTABUG. Maybe I tried to run
yum update while under a kernel with obsolete layout.

Note You need to log in before you can comment on or make changes to this bug.