Bug 485797 - [mga] crash if no xorg.conf and broken/missing DDC
[mga] crash if no xorg.conf and broken/missing DDC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 15:11 EST by Felix Miata
Modified: 2009-05-08 14:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 14:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (startx without xorg.conf) (27.07 KB, text/plain)
2009-02-16 15:11 EST, Felix Miata
no flags Details
/var/log/Xorg.setup.log (1.96 KB, text/plain)
2009-02-16 15:13 EST, Felix Miata
no flags Details

  None (edit)
Description Felix Miata 2009-02-16 15:11:56 EST
Created attachment 332098 [details]
Xorg.0.log (startx without xorg.conf)

Description of problem:
Fatal server error if runlevel 3 startx without xorg.conf. Gfxcard is Matrox G400 (rev 04). CRT display has dysfunctional DDC.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.9-1.fc11.i386

How reproducible:
Easy

Steps to Reproduce:
1.ensure /etc/X11/xorg.conf does not exist
2.runlevel 3
3.startx
  
Actual results:
Signal 11 server abort

Expected results:
X just works

Additional info:
I don't use Fedora much since bug 430836, but I tried to follow up to bug 448945 on another machine and found this. With the xorg.conf file I created by editing the result of system-config-display last October, X always runs without a startup crash. If I try to create a new xorg.conf with system-config-display, I get a crash similar to that starting with no xorg.conf.
Comment 1 Felix Miata 2009-02-16 15:13:11 EST
Created attachment 332100 [details]
/var/log/Xorg.setup.log
Comment 2 Matěj Cepl 2009-02-20 05:07:03 EST
Whoops.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812db4b]
1: /usr/bin/X(xf86SigHandler+0x9e) [0x80c0d0e]
2: [0x964400]
3: /usr/bin/X(xf86_wrap_crtc_notify+0x22) [0x80e6932]
4: /usr/lib/xorg/modules/extensions//libdri.so(DRIFinishScreenInit+0xa9) [0x291619]
5: /usr/lib/xorg/modules/drivers//mga_drv.so(MGADRIFinishScreenInit+0x65) [0x615415]
6: /usr/lib/xorg/modules/drivers//mga_drv.so [0x6084a3]
7: /usr/bin/X(AddScreen+0x198) [0x806b1a8]
8: /usr/bin/X(InitOutput+0x72e) [0x80a951e]
9: /usr/bin/X(main+0x1d3) [0x806b8c3]
10: /lib/libc.so.6(__libc_start_main+0xe5) [0x126735]
11: /usr/bin/X [0x806af31]

Fatal server error:
Caught signal 11.  Server aborting
Comment 3 Adam Jackson 2009-05-08 14:21:52 EDT
Fixed in xserver 1.6.0 and later.

Note You need to log in before you can comment on or make changes to this bug.