Bug 485823 - intel kms breaks Xv
Summary: intel kms breaks Xv
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IntelKMS
TreeView+ depends on / blocked
 
Reported: 2009-02-16 21:13 UTC by Bill Nottingham
Modified: 2018-04-11 07:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-27 20:32:16 UTC
Type: ---


Attachments (Terms of Use)
X log (21.56 KB, application/octet-stream)
2009-02-20 00:31 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2009-02-16 21:13:35 UTC
Description of problem:

After loading the intel KMS support with 'modprobe i915 modeset=1', Xv no longer works.

[notting@nostromo: ~]$ xvinfo 
X-Video Extension version 2.2
screen #0
 no adaptors present

The relevant portion of the log appears to be:

...
(II) intel(0): [DRI2] Setup complete
(**) intel(0): Kernel mode setting active, disabling FBC.
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: -1 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): Tiled allocation successful.
(WW) intel(0): Disabling Xv because the overlay register buffer allocation failed.
...

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.6.0-5.fc11.x86_64
xorg-x11-server-Xorg-1.5.99.902-10.fc11.x86_64
kernel-2.6.29-0.119.rc5.fc11.x86_64

How reproducible:

Well, only booted once so far, but there's no reason to think it isn't repeatable.

Steps to Reproduce:
1. Load modesetting driver
2. Start X
3. Attempt to use Xv
  
Actual results:

Fails.

Expected results:

Works.

Comment 1 Matěj Cepl 2009-02-16 23:07:22 UTC
I still believe that /var/log/Xorg.0.log would be useful.

Comment 2 Kristian Høgsberg 2009-02-17 14:23:32 UTC
(In reply to comment #1)
> I still believe that /var/log/Xorg.0.log would be useful.

No, it's ok, I'll take it from here - thanks.

Comment 3 Kristian Høgsberg 2009-02-17 14:24:48 UTC
Remove needinfo.

Comment 4 Kristian Høgsberg 2009-02-18 23:08:33 UTC
xorg-x11-drv-i810-2_6_0-6_fc11 should bring back the textured xv adaptor.

Comment 5 Bill Nottingham 2009-02-20 00:31:39 UTC
Created attachment 332657 [details]
X log

xorg-x11-server-Xorg-1.5.99.903-3.fc11.x86_64
xorg-x11-drv-i810-2.6.0-6.fc11.x86_64
kernel-2.6.29-0.134.rc5.git2.fc11.x86_64

It still fails.

X-Video Extension version 2.2
screen #0
 no adaptors present

Comment 6 Michael Monreal 2009-02-20 15:30:30 UTC
What is the "correct" way to enable KMS for Intel?

I tries "options i915 modeset=1" in one of the modprobe.d/ files but with that, X never really draws anything after boot and I cannot switch to a VT either...

Comment 7 Bill Nottingham 2009-02-20 15:37:40 UTC
With kernel >= 0.122, it should be enabled by default. Otherwise, you have to load i915 with modeset=1 before starting X.

Comment 8 Bill Nottingham 2009-02-27 20:32:16 UTC
With:

2.6.29-0.157.rc6.git2.fc11.x86_64
xorg-x11-drv-intel-2.6.0-9.fc11.x86_64

it works now again.


Note You need to log in before you can comment on or make changes to this bug.