Bug 485836 - noarch srpms produced by rawhide are built for every arch
noarch srpms produced by rawhide are built for every arch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-02-16 17:11 EST by Nicolas Mailhot
Modified: 2013-01-10 00:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 03:30:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-02-16 17:11:19 EST
A scratch build of two noarch srpms produced by rpm-build-4.6.0-4.fc11.x86_64 resulted in a duplicated build on ppc,ppc64,x86_64,x86.

A scratch build of a srpm with a similar spec file but produced by older rpm-builds resulted in the normal build.

Mike Bonnet says koji is fine and rawhide rpm-build is broken.

The F11 mass rebuild will use rawhide rpm-build, so unless it is fixed fast the load for noarch packages will be multiplied by 4.

Unadultered irc log:

(22:24:07) nim-nim: is it normal that when you do a scratch build for a noarch package
(22:24:16) nim-nim: koji builds in 4 times
(22:24:37) nim-nim: in ppc, ppc64, i386, and x86_64 ???
(22:24:54) notting: skvidal: 'Transaction test succeeded \n Running transaction \n <thunk>'. it's unstuck now, but it took it a few minutes
(22:24:57) ffesti: nim-nim, real noarch package?
22:25
(22:25:15) nim-nim: ffesti: real noarch package
(22:25:31) nim-nim: ffesti: or it would have failed the build, right?
(22:25:37) ffesti: hmm, I suggested that but I don't think it is intentional
(22:25:49) nim-nim: ffesti: http://koji.fedoraproject.org/koji/taskinfo?taskID=1131546
(22:26:26) nim-nim: ffesti: the page plainly states Arch  noarch
(22:26:51) ffesti: nim-nim, you need to ask our koji gurus
(22:27:06) nim-nim: ffesti: who are the koji gurus?
(22:27:13) mbonnet: nim-nim: that's not a noarch build.  Do you have "BuildArch: noarch" in the specfile?
(22:27:14) ffesti: #koji
(22:28:04) dgilmore: nim-nim: whatever you did when you built your srpm it doesnt think its noarch
(22:28:58) nim-nim: dgilmore: well, it only produces noarch packages
(22:29:22) nim-nim: dgilmore: and since the noarch subpackage feature it's not here yet, I'd say it's a noarch package ;)
dgilmore dgregor 
(22:29:37) nim-nim: dgilmore: it's even written so on the koji page
22:30
(22:30:15) mbonnet: nim-nim: if it only produces noarch subpackages, why isn't the main build noarch as well?
mbonnet mbonnet__ 
(22:30:37) dgilmore: nim-nim: does it have BuildArch: noarch in it?
(22:30:39) mbonnet: nim-nim: the noarch subpackage support is only for arch-specific builds that produce noarch subpackages
dgilmore dgregor 
(22:30:50) nim-nim: dgilmore: of course it has BuildArch:     noarch
(22:31:01) dgilmore: nim-nim: in the main section?
dgilmore dgregor 
(22:31:10) nim-nim: dgilmore: yes
dgilmore dgregor 
(22:31:33) nim-nim: dgilmore: you can check the koji-produced srpm if you don't believe me
mbonnet mbonnet__ 
(22:33:00) nim-nim: mbonnet: I don't know what you mean by "main build" but the root koji page about this scratch build plainly states koji thought it was building a noarch package
(22:33:27) nim-nim: mbonnet: except it decided to do it four times on all arches :p
(22:34:31) dgilmore: rpm -qp --queryformat="%{arch}\n" /mnt/koji/work/cli-build/1234818068.8308699.daJkahKI/dejavu-fonts-2.28-5.fc11.src.rpm
(22:34:35) dgilmore: x86_64
(22:34:43) mbonnet: nim-nim: that doesn't mean what you think it means
dgilmore dgregor 
(22:34:54) mbonnet: nim-nim: 'build' tasks are always noarch
22:35
(22:35:09) nim-nim: mbonnet, dgilmore anyway it did it again on http://koji.fedoraproject.org/koji/taskinfo?taskID=1131535
(22:35:22) nim-nim: which is an even simpler package with no subpackaging at all
(22:35:39) mbonnet: nim-nim: does "BuildArch: noarch" appear in the specfile before any %package defines?
(22:35:46) mbonnet: nim-nim: please post your specfile somewhere
(22:39:16) nim-nim: mbonnet: here http://nim.fedorapeople.org/apanov-edrip-fonts.spec
mbonnet mbonnet__ 
(22:39:34) nim-nim: mbonnet: but really I just downloaded the koji srpm and extracted the spec
mbonnet mbonnet__ 
(22:39:58) nim-nim: mbonnet: i was testing behdad's autoprovides stuff on old srpm I didn't change recently
22:40
(22:41:10) mbonnet: nim-nim: I don't know what %_font_pkg does, but it's possible it's confusing old (RHEL-5) rrm on the koji builders
mbonnet mbonnet__ 
(22:42:26) nim-nim: mbonnet: scores of packages have been built with this macro in the last two months without anyone noticing a problem
(22:42:43) mbonnet: nim-nim: well nothing has changed in koji recently
(22:43:01) nim-nim: though I don't think many people tried scratch builds
(22:43:55) nim-nim: maybe that's a change on the koji client side?
(22:44:05) nim-nim: many rpm changes have been pushed recently
(22:44:55) mbonnet: nim-nim: koji client could not cause that
(22:48:14) nim-nim: mbonnet: anyway http://koji.fedoraproject.org/koji/taskinfo?taskID=1131534 was build a few minutes before as scratch build too with the same macro and koji only build it one time
(22:48:49) nim-nim: so something funny happened *very* recently
(22:49:54) dgilmore: nim-nim: nothing has changed in koji client/server in months
22:50
(22:50:13) dgilmore: nothing thats been deployed anyway
(22:50:50) nim-nim: dgilmore: I only point the evidence, nothing changed my side either
(22:51:16) mbonnet: nim-nim: were the srpms built with different versions of rpmbuild?
(22:52:07) nim-nim: mbonnet: I think the two srpms with strange behaviour were just rebuilt with "make srpm" on a very up to date rawhide system
(22:52:46) nim-nim: mbonnet: the other one was produced by spot a few days ago on his box
(22:52:49) mbonnet: nim-nim: what about the srpm with non-strange behavior?
(22:54:17) nim-nim: mbonnet: timestamp says it's about 10 days old
(22:54:36) nim-nim: (the other one is the non-strange srpm=
(22:55:52) mbonnet: nim-nim: [mikeb@burren koji]$ rpm -q --qf '%{BUILDARCHS}\n' -p /tmp/apanov-edrip-fonts-20081007-4.fc11.src.rpm
(22:55:52) mbonnet: (none)
(22:55:52) mbonnet: [mikeb@burren koji]$ rpm -q --qf '%{BUILDARCHS}\n' -p /tmp/bpg-fonts-20090205-1.fc11.src.rpm
(22:55:52) mbonnet: noarch
(22:55:52) mbonnet: [mikeb@burren koji]$
(22:56:11) mbonnet: nim-nim: something wrong in the srpm-building process
(22:56:44) nim-nim: $ rpm -q rpm-build
(22:56:44) nim-nim: rpm-build-4.6.0-4.fc11.x86_64
mbonnet mbonnet__ 
(22:57:13) nim-nim: mbonnet: well, the something very wrong is in the rawhide rpm-build I think
(22:57:37) mbonnet: nim-nim: I don't know what's wrong, that's not my department.  I'm just saying that apanov-edrip-fonts is getting built on every arch because the srpm doesn't have the BUILDARCHS tag set to "noarch".
(22:57:51) mbonnet: nim-nim: file a bug with rpm
mbonnet mbonnet__ 
(22:58:42) nim-nim: mbonnet: just pointing that *every* rawhide noarch package is going to be rebuilt with this rpm-build next week
mbonnet mbonnet__ 
(22:59:01) mbonnet: nim-nim: then please file the bug quickly :)
(22:59:11) nim-nim: mbonnet: should I block something particular to make f13 notice?
(22:59:22) mbonnet: nim-nim: *shrug*
(22:59:33) mbonnet: nim-nim: maybe cc him on the bug?
(22:59:43) nim-nim: cheating
(22:59:45) nim-nim: ok :p
Comment 1 Nicolas Mailhot 2009-02-16 17:27:17 EST
To reproduce:

1. co a simple noarch package such as xgridfit on a rawhide system
2. make srpm in devel
3. scratch-build the result

Example
http://koji.fedoraproject.org/koji/taskinfo?taskID=1131787
Comment 2 Jindrich Novy 2009-02-17 03:30:28 EST
Should be fixed now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.