Bug 485844 - gnome-power-manager: Suspend not working on lid close (F11/rawhide)
gnome-power-manager: Suspend not working on lid close (F11/rawhide)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 18:43 EST by Nigel Jones
Modified: 2009-03-06 05:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 05:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome power manager log (gz) (2.60 KB, application/octet-stream)
2009-02-25 10:11 EST, Nigel Jones
no flags Details

  None (edit)
Description Nigel Jones 2009-02-16 18:43:49 EST
Description of problem:

Closing laptop lid does not switch to suspend on either AC or battery despite gnome-power-manager beeing configured to transition to suspend on both AC and battery power

Left click->suspend works fine, as does resume
Value of /proc/acpi/button/lid/LID correctly changes from "open" to "closed" when lid is shut

This system is a Thinkpad T60p (latest bios) which worked correctly under F10, and which was then "upgraded" to rawhide around alpha time. Video is ati V5200

Version-Release number of selected component (if applicable):
gnome-power-manager-2.25.91-1.fc11.i386
DeviceKit-power-006-1.fc11.i386
xorg-x11-drv-ati-6.10.0-2.fc11.i386
kernel-PAE-2.6.29-0.119.rc5.fc11.i686

How reproducible:

Every time

Steps to Reproduce:
1.Closelid
2.
3.
  
Actual results:
nothing

Expected results:
suspend

Additional info:
Comment 1 Richard Hughes 2009-02-25 04:12:01 EST
can you do:

killall gnome-power-manager
gnome-power-manager --verbose

and then open and shut the lid a few times, and then post the complete log. Thanks.
Comment 2 Nigel Jones 2009-02-25 10:10:29 EST
Thanks. Basically there are no entries when the lid is opened/closed, so clearly the event isn't making it through. I will attach somewhere but looks like the issue may lie elsewhere

From the kernel debug log all I see during boot is 
Feb 25 10:26:27 snowdon kernel: input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
Feb 25 10:26:27 snowdon kernel: ACPI: Lid Switch [LID]

Running acpid with debug I get:
acpid: received event "button/lid LID 00000080 0000000d"
acpid: blocking signals for rule lock
acpid: rule from 7190[0:0] matched
acpid: notifying client 7190[0:0]
acpid: rule from 3096[68:68] matched
acpid: notifying client 3096[68:68]
acpid: rule from /etc/acpi/events/ultrabay-eject did not match
acpid: rule from /etc/acpi/events/ultrabay-insert did not match
acpid: rule from /etc/acpi/events/power.conf did not match
acpid: unblocking signals for rule lock
acpid: 2 total rules matched
acpid: completed event "button/lid LID 00000080 0000000d"

[jonesn@snowdon ~]$ ps -ef | egrep "7190|3096"
68        3096  2951  0 10:26 ?        00:00:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root      7190  7189  9 10:45 tty1     00:23:41 /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-fC8jma/database -nolisten tcp vt1
jonesn   13339 13176  0 15:07 pts/4    00:00:00 egrep 7190|3096
Comment 3 Nigel Jones 2009-02-25 10:11:06 EST
Created attachment 333168 [details]
gnome power manager log (gz)
Comment 4 Nigel Jones 2009-03-02 15:50:11 EST
Now appears working with

gnome-power-manager-2.25.91-7.fc11.i586
DeviceKit-power-006-3.fc11.i586
xorg-x11-drv-ati-6.11.0-1.fc11.i586
kernel-PAE-2.6.29-0.176.rc6.git5.fc11.i686

Note You need to log in before you can comment on or make changes to this bug.