Bug 485874 - Kernel frequently hangs in boot
Kernel frequently hangs in boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 02:00 EST by Mace Moneta
Modified: 2009-03-12 13:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 13:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of boot hang (890.39 KB, image/jpeg)
2009-02-24 12:48 EST, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2009-02-17 02:00:28 EST
Description of problem:

The kernel will frequently hang at the point where it's loading the keyboard keymap (the "loading" message itself is incomplete and overlaid with trash).  If I reboot a few times, it will proceed.  I've tried various options, including acpi=off, with no effect.

Version-Release number of selected component (if applicable):

kernel-2.6.29-0.122.rc5.fc11.x86_64

How reproducible:

About 8 or nine times out of 10, it will fail to boot.

Steps to Reproduce:
1.Boot
2.
3.
  
Actual results:

Usually, a hang.  I can alt-sysreq reisub, but there is nothing logged in syslog to indicate the error.

Expected results:

Normal boot.

Additional info: Upgraded to rawhide from F10 via preupgrade.
Comment 1 Clark Williams 2009-02-19 10:08:08 EST
I'm seeing this on a T60, where USB devices have been enumerated and Synaptics firmware has been loaded. Kernel is alive but stopped with nothing ready to run (sysrq-t). 

I really suspect something in the bootup userspace logic, because this happens not just on the fedora kernel, but on other kernels as well (e.g. the RT kernel). 

I'm trying to figure out who's waiting for an event that either is not going to happen or has already happened and just been missed.
Comment 2 Mace Moneta 2009-02-24 12:48:47 EST
Created attachment 333068 [details]
Image of boot hang

I thought this photo might be useful, to add some context to the hang.
Comment 3 Mace Moneta 2009-02-24 16:47:50 EST
Just noting that this continues with kernel-2.6.29-0.148.rc6.fc11.x86_64
Comment 4 Mace Moneta 2009-02-24 16:50:05 EST
The first messages after the hang point, on a successful boot:

Console: switching to colour frame buffer device 240x75
[drm] DAC-6: set mode 1920x1200 22
fb0: inteldrmfb frame buffer device
registered panic notifier
[drm] Initialized i915 1.6.0 20080730 on minor 0
Comment 5 Mace Moneta 2009-03-07 16:41:25 EST
Just noting no change with kernel-2.6.29-0.207.rc7.fc11.x86_64
Comment 6 Kyle McMartin 2009-03-10 13:52:48 EDT
I suspect this is an issue due to the debug kernels... I'll upload some no-debug kernels, would you please test them?
Comment 7 Mace Moneta 2009-03-10 14:01:48 EDT
Sure, no problem.
Comment 8 Mace Moneta 2009-03-12 02:02:53 EDT
I just installed kernel-2.6.29-0.237.rc7.git4.fc11.x86_64.rpm and rebooted successfully four times in a row.
Comment 9 Josh Boyer 2009-03-12 10:32:28 EDT
For those of you still getting hangs, could you try adding 'plymouth:debug' to the kernel command line and seeing what the output is?

I had a machine exhibiting similar symptoms and it wound up being a broken initrd that didn't contain the drivers for the root disks.
Comment 10 Kyle McMartin 2009-03-12 10:54:26 EDT
Just fyi, I got sidetracked by some build failures, but there's a nodebug build in progress here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1238109
Comment 11 Mace Moneta 2009-03-12 13:49:31 EDT
I installed kernel-2.6.29-0.244.rc7.git5.nodebug.fc11.x86_64.  As with kernel-2.6.29-0.237.rc7.git4.fc11.x86_64.rpm (comment 8), I rebooted several times. Powered off/on/booted.  Rebooted a few more times.

No problems encountered.  I'm closing this issue against rawhide.

Note You need to log in before you can comment on or make changes to this bug.