Bug 485880 - missing options in rhnpush.8
missing options in rhnpush.8
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Mráka
Jan Hutař
:
Depends On:
Blocks: sat550-blockers 855837
  Show dependency treegraph
 
Reported: 2009-02-17 03:04 EST by Jan Hutař
Modified: 2012-10-15 05:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhnpush-5.5.28-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 05:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-02-17 03:04:44 EST
Description of problem:
There are missing options in the rhnpush.8 man-page, but
'--help' lists them.


Version-Release number of selected component (if applicable):
rhnpush-0.4.2-1.el5sat


How reproducible:
always


Steps to Reproduce:
1. # rhnpush --help
2. # man rhnpush


Actual results:
Missing in man page:
	--no-cache
	--no-session-caching
	-N


Expected results:
All options should be in both outputs (man-page and --help message)


Additional info:
Used mmalik's script for this (gives some false-positives):
# cd /mnt/qa/scratch/mmalik/options-comparator/
# ./compare-options.sh `type -p rhnpush`
Program path:
	/usr/bin/rhnpush
Guessing man page path:
	/usr/share/man/man8/rhnpush.8.gz
The binary analysis was NOT done
Doing man page vs. usage message comparison

The program reported 40 option(s)
The man page reported 37 option(s)
37 COMMON option(s):
	--channel
	--count
	--dir
	--exclude
	--extended-test
	--force
	--header
	--help
	--list
	--new-cache
	--newest
	--nosig
	--nullorg
	--orgid
	--password
	--reldir
	--server
	--source
	--stdin
	--test
	--tolerant
	--usage
	--username
	--verbose
	-?
	-X
	-c
	-d
	-h
	-l
	-n
	-o
	-p
	-r
	-s
	-u
	-v
3 option(s) reported by the program ONLY:
	--no-cache
	--no-session-caching
	-N
0 option(s) reported by the man page ONLY:
Comment 2 Jan Hutař 2009-04-01 02:30:54 EDT
Hello,
I have checked man-page from:

Satellite-5.3.0-RHEL5-re20090327.0-x86_64/Satellite/rhnpush-0.4.2-1.el5sat.noarch.rpm

and it is still not fixed there (I'm searching for "--no-cache", "--no-session-caching" and "-N" in the man-page).

Changelog of the package is (if that is important):

* Thu Feb 12 2009 jesus m. rodriguez <jesusr@redhat.com> 0.4.2-1
- replace "!#/usr/bin/env python" with "!#/usr/bin/python"
- 436332 - return an error code other than 0 if there is a mismatch
- more changes for nvrea error handling
- 241127 - Solaris patch-requires fix
- 241369 - --force and --nullorg are incompatible options
- bump up version 0.4.1
- 461701 - don't use cached session if username is provided on commandline

* Thu Sep 25 2008 Milan Zazrivec 0.3.1-1
- Bumped version for spacewalk 0.3

* Wed Sep 03 2008 Milan Zazrivec 0.2.2-1
- Bumped version for spacewalk 0.2

* Thu Nov 02 2006 James Bowes <jbowes@redhat.com> - 4.2.0-48
- Initial seperate packaging.

Thank you in advance,
Jan
Comment 3 Pradeep Kilambi 2009-04-01 09:55:53 EDT
hrm looks like the latest pkgs were not picked up by the build. I'll make sure this gets into the next iso drop. moving back to modified.
Comment 4 Jan Hutař 2009-05-21 04:37:39 EDT
VERIFIED on 20090507.1 - rhnpush-5.3.1-5.el5sat.noarch
Comment 5 Miroslav Suchý 2009-08-25 11:15:00 EDT
FAILQA 
the option -N is presented in SYNOPSIS section, but is not repeated in OPTIONS section.
Comment 6 Clifford Perry 2009-08-25 11:27:01 EDT
punted off 530.
Comment 7 Miroslav Suchý 2011-06-20 10:40:59 EDT
Fixed in spacewalk.git as commit 688ced66c8080b616b2bc17cb67c93a617ca8282
Comment 9 Matej Kollar 2012-08-20 08:48:45 EDT
I have verified that in rhnpush-5.5.42-5.el6sat.noarch is documentation where all switches printed out by --help are also in man page (including those mentioned in Comment 0)
Comment 12 errata-xmlrpc 2012-10-15 05:06:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1368.html

Note You need to log in before you can comment on or make changes to this bug.